栈-uva 442

Your job is to write a program that determines the number of elementary multiplications needed for a given evaluation strategy.
Input Specification
Input consists of two parts: a list of matrices and a list of expressions.
The first line of the input file contains one integer n (  ), representing
 the number of matrices in the first part. The next n lines each contain one capital letter, specifying the name of the matrix, and two integers, specifying the number of rows and columns of the matrix.
The second part of the input file strictly adheres to the following syntax (given in EBNF):
SecondPart = Line { Line } <EOF>
Line       = Expression <CR>
Expression = Matrix | "(" Expression Expression ")"
Matrix     = "A" | "B" | "C" | ... | "X" | "Y" | "Z"
Output Specification
For each expression found in the second part of the input file, print one line containing the word "error" if evaluation of the expression leads to an error due to non-matching matrices. Otherwise print
 one line containing the number of elementary multiplications needed to evaluate the expression in the way specified by the parentheses.
Sample Input
9
A 50 10
B 10 20
C 20 5
D 30 35
E 35 15
F 15 5
G 5 10
H 10 20
I 20 25
A
B
C
(AA)
(AB)
(AC)
(A(BC))
((AB)C)
(((((DE)F)G)H)I)
(D(E(F(G(HI)))))
((D(EF))((GH)I))
Sample Output
0
0
0
error
10000
error
3500
15000
40500
47500
15125
--------------------- 
#include<cstdio>
#include<stack>
#include<iostream>
#include<string>
using namespace std;
struct Matrix{
 int a,b;
 Matrix(int a=0,int b=0):a(a),b(b){} //a,b成员变量;a(a),b(b){}构造函数 m[26]结构体数组
}m[26];
stack<Matrix>s;//构建一个先进后出的空栈;
int main()
{
 int n;
 cin>>n;
 for(int i=0;i<n;i++)
 {
  string name;
  cin>>name;
  int k=name[0]-'A';//转为数字
  cin>>m[k].a>>m[k].b;
 }
 string expr;
 while(cin>>expr){
  int len=expr.length();
  bool error=false;
  int ans=0;
  for(int i=0;i<len;i++){
   if(isalpha(expr[i])) s.push(m[expr[i]-'A']);
   else if(expr[i]==')'){
    Matrix m2=s.top();s.pop();
    Matrix m1=s.top();s.pop();
    if(m1.b!=m2.a){
     error=true;break;
    }
    ans+=m1.a*m1.b*m2.b;
    s.push(Matrix(m1.a,m2.b));
   }
  }
  if(error) printf("error\n");
  else printf("%d\n",ans);
 }
 return 0;
 }

猜你喜欢

转载自www.cnblogs.com/123123123gg/p/9785573.html