POJ 1979

  • 原题目:
    Description
    There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.
    Write a program to count the number of black tiles which he can reach by repeating the moves described above.
    Input
    The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.
    There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.
    ‘.’ - a black tile
    ‘#’ - a red tile
    ‘@’ - a man on a black tile(appears exactly once in a data set)
    The end of the input is indicated by a line consisting of two zeros.
    Output

    For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

    Sample Input

    6 9
    ....#.
    .....#
    ......
    ......
    ......
    ......
    ......
    #@...#
    .#..#.
    11 9
    .#.........
    .#.#######.
    .#.#.....#.
    .#.#.###.#.
    .#.#..@#.#.
    .#.#####.#.
    .#.......#.
    .#########.
    ...........
    11 6
    ..#..#..#..
    ..#..#..#..
    ..#..#..###
    ..#..#..#@.
    ..#..#..#..
    ..#..#..#..
    7 7
    ..#.#..
    ..#.#..
    ###.###
    ...@...
    ###.###
    ..#.#..
    ..#.#..
    0 0
    

    Sample Output

    45
    59
    6
    13
    
  • 题目大意:
    给出一个w列和h行的方阵,方阵中有’.’,’#‘和’@’。其中’.‘是可以移动的地方,’#‘是红色的砖,是不可以移动的地 方,’@'是最初人的地点就(图的入口),人可以上下左右移动,以0 0 为结束。
    要求输出人可以移动的砖的个数。该题利用搜索。

注意:
先输入w,然后输入h,但是w是列数,h是行数。

  • 代码:
#include<iostream>
#include<cstring>
using namespace std;

void dfs(int x,int y);
int w,h,tmp=0;

char ma[100][100];
int dx[4]={0,0,1,-1};
int dy[4]={1,-1,0,0};

int main(){
	while(cin>>h>>w){
		if(w==0&&h==0)  break;
		memset(ma,'0',sizeof(ma));
		int ax,ay;
		for(int i=0;i<w;i++){
			for(int j=0;j<h;j++){
				cin>>ma[i][j];
				if(ma[i][j]=='@'){
					ax=i;
					ay=j;
				}
			}
		}
		tmp=0;
		dfs(ax,ay);
		cout<<tmp<<endl;
	}
	return 0;
}

void dfs(int x,int y){
	ma[x][y]='#';
	tmp++;
	for(int i=0;i<4;i++){
		int nx=x+dx[i];
		int ny=y+dy[i];
		if(ma[nx][ny]=='.'&&nx>=0&&nx<w&&ny>=0&&ny<h&&ma[nx][ny]=='.'){
			dfs(nx,ny);
		}
	}
}
Select Code
#include<iostream>
#include<cstring>
using namespace std;

void dfs(int x,int y);
int w,h,tmp=0;

char ma[100][100];
int dx[4]={0,0,1,-1};
int dy[4]={1,-1,0,0};

int main(){
	while(cin>>h>>w){
		if(w==0&&h==0)  break;
		memset(ma,'0',sizeof(ma));
		int ax,ay;
		for(int i=0;i<w;i++){
			for(int j=0;j<h;j++){
				cin>>ma[i][j];
				if(ma[i][j]=='@'){
					ax=i;
					ay=j;
				}
			}
		}
		tmp=0;
		dfs(ax,ay);
		cout<<tmp<<endl;
	}
	return 0;
}

void dfs(int x,int y){
	ma[x][y]='#';
	tmp++;
	for(int i=0;i<4;i++){
		int nx=x+dx[i];
		int ny=y+dy[i];
		if(ma[nx][ny]=='.'&&nx>=0&&nx<w&&ny>=0&&ny<h&&ma[nx][ny]=='.'){
			dfs(nx,ny);
		}
	}
}

POJ上不支持bits/stdc++的头文件,很尴尬。

猜你喜欢

转载自blog.csdn.net/sunowsir/article/details/83115927