Pet

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/PeopleOfVision/article/details/82666512

Problem Description

One day, Lin Ji wake up in the morning and found that his pethamster escaped. He searched in the room but didn’t find the hamster. He tried to use some cheese to trap the hamster. He put the cheese trap in his room and waited for three days. Nothing but cockroaches was caught. He got the map of the school and foundthat there is no cyclic path and every location in the school can be reached from his room. The trap’s manual mention that the pet will always come back if it still in somewhere nearer than distance D. Your task is to help Lin Ji to find out how many possible locations the hamster may found given the map of the school. Assume that the hamster is still hiding in somewhere in the school and distance between each adjacent locations is always one distance unit.

Input

The input contains multiple test cases. Thefirst line is a positive integer T (0<T<=10), the number of test cases. For each test cases, the first line has two positive integer N (0<N<=100000) and D(0<D<N), separated by a single space. N is the number of locations in the school and D is the affective distance of the trap. The following N-1lines descripts the map, each has two integer x and y(0<=x,y<N), separated by a single space, meaning that x and y is adjacent in the map. Lin Ji’s room is always at location 0.

Output

For each test case, outputin a single line the number of possible locations in the school the hamster may be found.

Sample Input

1
10 2
0 1
0 2
0 3
1 4
1 5
2 6
3 7
4 8
6 9

Sample Output

 

2

题目的大意是:给了一颗树,N-1是树中节点与节点之间的关系,D表示某一个节点到根节点的距离,求出所有节点中到根节点的距离大于D的节点的个数。

#include <iostream>
#include<cstdio>
#include<algorithm>
#include<string>
#include<cstring>
using namespace std;
const int MAXN=100001;
int a[MAXN];

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {

      int  n,d,x,y;
      int counts=0;
      scanf("%d%d",&n,&d);
      memset(a,0,sizeof(a));
      for(int i=0;i<n-1;i++)
      {
          scanf("%d%d",&x,&y);
          a[y]=a[x]+1;
      }
      for(int i=0;i<=n-1;i++)
      {
          if(a[i]>d)
           counts++;
      }
       printf("%d\n",counts);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/PeopleOfVision/article/details/82666512
Pet