Ubiquitous Religions (并查集)


    There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in.

    You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.
Input
    The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.
Output
    For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.
Sample Input

    10 9
    1 2
    1 3
    1 4
    1 5
    1 6
    1 7
    1 8
    1 9
    1 10
    10 4
    2 3
    4 5
    4 8
    5 8
    0 0

Sample Output

    Case 1: 1
    Case 2: 7

题意:给出学生数n和m行信息,每行包含两个整数 i 和 j,表示学生i和j信仰相同的宗教。学生编号从1到n。

求一个学校的学生信仰宗教的最大种类数。

分析:并查集模板,理解了题意就容易写了。

#include<stdio.h>
int f[50000],n,m,k,sum=0;
void init()
{
	int i;
	for(i = 1; i <= n; i ++)
		f[i] = i;
	return;
}
 
int find(int v)
{
	if(f[v] == v)
		return v;
	else
	{
		//这里是路径压缩,每次在函数返回时,把遇到的结点改为根结点的编号
		//提高找到根结点的速度 
		f[v] = find(f[v]);
		return f[v];
	}
}
 
void merge(int x,int y)//合并两个子集的函数 
{
	int t1,t2;
	t1 = find(x);
	t2 = find(y);
	if(t1 != t2)
	{
		f[t1] = t2;
	} 
	 return;
}
int main()
{
	int i,j,x,y,count=1;
	while(scanf("%d%d",&n,&m), n != 0 || m != 0)
	{
		sum = 0;
		init();
		for(i = 1; i <= m; i ++)
		{
			scanf("%d%d",&x,&y);
			merge(x,y);
		}
		for(i = 1; i <= n; i ++)
		{
			printf("%d ",f[i]);
			if(f[i] == i)
				sum ++;
		}
		printf("\n");
		printf("Case %d: %d\n",count ++,sum);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/queen00000/article/details/81477109