POJ2251 Dungeon Master BFS广搜

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/Hacker_Wind/article/details/79937313
You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides.

Is an escape possible? If yes, how long will it take?
Input
The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size).
L is the number of levels making up the dungeon.
R and C are the number of rows and columns making up the plan of each level.
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a '#' and empty cells are represented by a '.'. Your starting position is indicated by 'S' and the exit by the letter 'E'. There's a single blank line after each level. Input is terminated by three zeroes for L, R and C.
Output
Each maze generates one line of output. If it is possible to reach the exit, print a line of the form
Escaped in x minute(s).

where x is replaced by the shortest time it takes to escape.
If it is not possible to escape, print the line
Trapped!
解析:三维空间的BFS,只是把x,y两个变量变为x,y,z三个变量,改动位移数组即可。
Sample Input
3 4 5
S....
.###.
.##..
###.#

#####
#####
##.##
##...

#####
#####
#.###
####E

1 3 3
S##
#E#
###

0 0 0
Sample Output
Escaped in 11 minute(s).
Trapped!
 
#include <iostream>
#include <cstdlib>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <queue>
#include <cmath>
using namespace std;
//#define PI 3.14159265358979323
#define inf 0x3f3f3f3f
#define maxn 8   
int l,r,c;
char ch[35][35][35];
int a[6][3]={{1,0,0},{-1,0,0},{0,1,0},{0,-1,0},{0,0,1},{0,0,-1}};
int vis[35][35][35];
int sx,sy,sz,ex,ey,ez;
struct Map
{
    int x,y,z;
    int step;
};
int check(Map m)
{
    if(vis[m.x][m.y][m.z]==1||ch[m.x][m.y][m.z]=='#'||m.x>=r||m.x<0||m.y>=c||m.z<0||m.y<0||m.z>=l)
        return 0;
    else
        return 1;
}
int dfs()
{
    queue<Map> q;
    Map now,next;
    now.x=sx;
    now.y=sy;
    now.z=sz;
    now.step=0;
    q.push(now);
    vis[now.x][now.y][now.z]=1;
    while(!q.empty())
    {
        now=q.front();
        q.pop();

        if(now.x==ex&&now.y==ey&&now.z==ez)
            return now.step;
        for(int i=0;i<6;i++)
        {
            next.step=now.step;
            next.x=now.x+a[i][0];
            next.y=now.y+a[i][1];
            next.z=now.z+a[i][2];
            if(!check(next))
            continue;
            next.step=now.step+1;
                q.push(next);
                vis[next.x][next.y][next.z]=1;

        }

    }
    return 0;
}
int main()
{
    while(cin>>l>>r>>c)
    {
        if(l==0&&r==0&&c==0)
            return 0;
        memset(vis,0,sizeof(vis));
        for(int i=0;i<l;i++)
        {
            for(int j=0;j<r;j++)
            {
                for(int k=0;k<c;k++)
                {
                    cin>>ch[j][k][i];
                    if(ch[j][k][i]=='S')
                    {
                        sz=i;
                        sy=k;
                        sx=j;
                    }
                    if(ch[j][k][i]=='E')
                    {
                        ex=j;
                        ey=k;
                        ez=i;
                    }
                }
                //getchar();
            }
            getchar();

        }
        int ans=dfs();
        if(ans==0)
            cout<<"Trapped!"<<endl;
        else
        cout<<"Escaped in "<<ans<<" minute(s)."<<endl;
    }

    return 0;
}

猜你喜欢

转载自blog.csdn.net/Hacker_Wind/article/details/79937313
今日推荐