TOJ 1704: Cheapest Palindrome 区间DP

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/TheWise_lzy/article/details/83153744

1704: Cheapest Palindrome

描述

Keeping track of all the cows can be a tricky task so Farmer John has installed a system to automate it. He has installed on each cow an electronic ID tag that the system will read as the cows pass by a scanner. Each ID tag's contents are currently a single string with length M (1 ≤ M ≤ 2,000) characters drawn from an alphabet of N (1 ≤ N ≤ 26) different symbols (namely, the lower-case roman alphabet).

Cows, being the mischievous creatures they are, sometimes try to spoof the system by walking backwards. While a cow whose ID is "abcba" would read the same no matter which direction the she walks, a cow with the ID "abcb" can potentially register as two different IDs ("abcb" and "bcba").

FJ would like to change the cows's ID tags so they read the same no matter which direction the cow walks by. For example, "abcb" can be changed by adding "a" at the end to form "abcba" so that the ID is palindromic (reads the same forwards and backwards). Some other ways to change the ID to be palindromic are include adding the three letters "bcb" to the begining to yield the ID "bcbabcb" or removing the letter "a" to yield the ID "bcb". One can add or remove characters at any location in the string yielding a string longer or shorter than the original string.

Unfortunately as the ID tags are electronic, each character insertion or deletion has a cost (0 ≤ cost ≤ 10,000) which varies depending on exactly which character value to be added or deleted. Given the content of a cow's ID tag and the cost of inserting or deleting each of the alphabet's characters, find the minimum cost to change the ID tag so it satisfies FJ's requirements. An empty ID tag is considered to satisfy the requirements of reading the same forward and backward. Only letters with associated costs can be added to a string.

输入

Line 1: Two space-separated integers: N and M 
Line 2: This line contains exactly M characters which constitute the initial ID string 
Lines 3..N+2: Each line contains three space-separated entities: a character of the input alphabet and two integers which are respectively the cost of adding and deleting that character.

输出

Line 1: A single line with a single integer that is the minimum cost to change the given name tag.

样例输入

3 4
abcb
a 1000 1100
b 350 700
c 200 800

样例输出

900

提示

If we insert an "a" on the end to get "abcba", the cost would be 1000. If we delete the "a" on the beginning to get "bcb", the cost would be 1100. If we insert "bcb" at the begining of the string, the cost would be 350 + 200 + 350 = 900, which is the minimum.

稍微想一下可以发现对于回文串来说,增加一个字母和减去一个字母效果是一样的,所以在输入的时候就可以直接取小作为这个字母的花费cost,然后区间DP倒着判,如果两端是一样的则直接等于上个状态的花费,若不同则对左边操作和右边操作取小。

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<iostream>
#include<string>
#include<algorithm>
#include<map>
#include<set>
#include<queue>
#include<vector>
using namespace std;
#define inf 0x3f3f3f3f
#define LL long long
char a[2005];
int cost[30],dp[2005][2005];
int main()
{
	int n,m,i,j,o,p;
	char x[2];
	scanf("%d%d",&n,&m);
	scanf("%s",a);
	for(i=0;i<n;i++)
	{
		scanf("%s%d%d",x,&o,&p);
		cost[x[0]-'a']=min(o,p);
	}
	memset(dp,0,sizeof dp);
	for(i=m-1;i>=0;i--)
	{
		for(j=i+1;j<m;j++)
		{
			if(a[i]==a[j])
			dp[i][j]=dp[i+1][j-1];
			else
			dp[i][j]=min(dp[i+1][j]+cost[a[i]-'a'],dp[i][j-1]+cost[a[j]-'a']);
			
			/*for(int o=0;o<m;o++)
			{
				for(int p=0;p<m;p++)
				{
					if(dp[o][p]==inf)
					printf("inf ");
					else
					printf("%d ",dp[o][p]);
				}			
				printf("\n");
			}*/
		}
	}
	printf("%d\n",dp[0][m-1]);
}

猜你喜欢

转载自blog.csdn.net/TheWise_lzy/article/details/83153744