2015长春区域赛 - F - Almost Sorted Array HDU - 5532

版权声明:随便写写,也不重要,欢迎挑错讨论 https://blog.csdn.net/qq_37305947/article/details/82658707

We are all familiar with sorting algorithms: quick sort, merge sort, heap sort, insertion sort, selection sort, bubble sort, etc. But sometimes it is an overkill to use these algorithms for an almost sorted array. 

We say an array is sorted if its elements are in non-decreasing order or non-increasing order. We say an array is almost sorted if we can remove exactly one element from it, and the remaining array is sorted. Now you are given an array a1,a2,…,ana1,a2,…,an, is it almost sorted?

Input

The first line contains an integer TT indicating the total number of test cases. Each test case starts with an integer nn in one line, then one line with nn integers a1,a2,…,ana1,a2,…,an. 

1≤T≤2000
2≤n≤105
1≤ai≤1051
There are at most 20 test cases with n>1000

Output

For each test case, please output "`YES`" if it is almost sorted. Otherwise, output "`NO`" (both without quotes).

Sample Input

3
3
2 1 7
3
3 2 1
5
3 1 4 1 5

Sample Output

YES
YES
NO

题意:给你个序列 让你判断去掉一个数,该数列是否是一个非递增序列或者是非递减序列。

思路:分别求最长上升子序列和最长下降子序列的长度 ,如果长度为n-1 或 n 则YES 否则NO(复杂度O(nlogn))

#include<bits/stdc++.h>
#define CaseT int t;scanf("%d",&t);while(t--)
#define ms(a,x) memset(a,x,sizeof(a))
using namespace std;

#define N 107
#define MAX 100002

typedef long long ll;

int n,m;
int a[MAX];
int d[MAX];
int u[MAX];
int b[MAX];

void solve(){
	int n;
	cin>>n;
	ms(a,0);ms(b,0);ms(d,0);ms(u,0);
	for(int i=1;i<=n;i++){
		scanf("%d",&a[i]);
		b[n-i+1]=a[i];
	}
	
	u[1]=a[1];
	d[1]=b[1];
	int up=1,down=1;
	for(int i=2;i<=n;i++){
		if(a[i]>=u[up])//非递减 就加上等号。
			u[++up]=a[i];
		else {
			int pos=upper_bound(u+1,u+1+up,a[i])-u;
			u[pos]=a[i];
		}
		
		if(b[i]>=d[down])
			d[++down]=b[i];
		else {
			int pos=upper_bound(d+1,d+1+down,b[i])-d;
			d[pos]=b[i];
		}
	}
	
	if(up==n||up==n-1||down==n||down==n-1)
		cout<<"YES\n";
	else cout<<"NO\n";
	
}
 
int main(){
	CaseT
	solve();
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_37305947/article/details/82658707