shift dote ---向量的计算--Java

版权声明:禁止转载,翻版必究 https://blog.csdn.net/qq_41341757/article/details/83584709

Problem Description

给出平面直角坐标系中的一点,并顺序给出n个向量,求该点根据给定的n个向量位移后的位置。

Input

多组输入,第一行是三个整数x,y,n,表示点的坐标(x,y),和向量的个数n。接下来n行,每行两个数xi,yi,表示第i个向量。题目中所有数据不会超出整形范围。
Output

每组输入输出一行,"(x,y)"表示点的最终位置。
Sample Input

0 0 1
2 3
0 0 2
1 2
2 3
Sample Output

(2,3)
(3,5)

import java.util.Scanner;



public class Main
{
	public static void main(String[] args)
	{
		Scanner reader=new Scanner(System.in);
		while(reader.hasNext())
		{
			int x=reader.nextInt();
			int y=reader.nextInt();
			int n=reader.nextInt();
			for(int i=1;i<=n;i++)
			{
				x=x+reader.nextInt();
				y=y+reader.nextInt();
			}
			System.out.println("("+x+","+y+")");
		}
		reader.close();
	}
}



猜你喜欢

转载自blog.csdn.net/qq_41341757/article/details/83584709