HDU - 人见人爱A+B

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/lzyws739307453/article/details/83245611

http://acm.hdu.edu.cn/showproblem.php?pid=2033

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Problem Description

HDOJ上面已经有10来道A+B的题目了,相信这些题目曾经是大家的最爱,希望今天的这个A+B能给大家带来好运,也希望这个题目能唤起大家对ACM曾经的热爱。
这个题目的A和B不是简单的整数,而是两个时间,A和B 都是由3个整数组成,分别表示时分秒,比如,假设A为34 45 56,就表示A所表示的时间是34小时 45分钟 56秒。

Input

输入数据有多行组成,首先是一个整数N,表示测试实例的个数,然后是N行数据,每行有6个整数AH,AM,AS,BH,BM,BS,分别表示时间A和B所对应的时分秒。题目保证所有的数据合法。

Output

对于每个测试实例,输出A+B,每个输出结果也是由时分秒3部分组成,同时也要满足时间的规则(即:分和秒的取值范围在0~59),每个输出占一行,并且所有的部分都可以用32位整数表示。

Sample Input

2
1 2 3 4 5 6
34 45 56 12 23 34

Sample Output

5 7 9
47 9 30

Problem solving report:

Description: 求两个时间数的相加和。

Problem solving: 按照秒分时的顺序相加,遵循60进1的原则。

#include <stdio.h>
int main()
{
	int n, i, a[5], b[5];
	scanf("%d", &n);
	while (n--)
	{
		for (i = 1; i <= 3; i++)
			scanf("%d", &a[i]);
		for (i = 1; i <= 3; i++)
			scanf("%d", &b[i]);
		for (i = 3; i >= 2; i--)
		{
			a[i] += b[i];        
			if (a[i] >= 60)        
			{
				a[i] -= 60;
				a[i - 1]++;
			}
		}
		a[1] += b[1];
		for (i = 1; i <= 2; i++)
			printf("%d ", a[i]);
		printf("%d\n", a[3]);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/lzyws739307453/article/details/83245611
今日推荐