I - Strategic Game (二分图最大匹配的性质)

I - Strategic Game

Bob enjoys playing computer games, especially strategic games, but sometimes he cannot find the solution fast enough and then he is very sad. Now he has the following problem. He must defend a medieval city, the roads of which form a tree. He has to put the minimum number of soldiers on the nodes so that they can observe all the edges. Can you help him?

Your program should find the minimum number of soldiers that Bob has to put for a given tree.

The input file contains several data sets in text format. Each data set represents a tree with the following description:

the number of nodes
the description of each node in the following format
node_identifier:(number_of_roads) node_identifier1 node_identifier2 ... node_identifier
or
node_identifier:(0)

The node identifiers are integer numbers between 0 and n-1, for n nodes (0 < n <= 1500). Every edge appears only once in the input data.

For example for the tree:



the solution is one soldier ( at the node 1).

The output should be printed on the standard output. For each given input data set, print one integer number in a single line that gives the result (the minimum number of soldiers). An example is given in the following table:

Input

4
0:(1) 1
1:(2) 2 3
2:(0)
3:(0)
5
3:(3) 1 4 2
1:(1) 0
2:(0)
0:(0)
4:(0)

Output

1
2

Sample Input

4
0:(1) 1
1:(2) 2 3
2:(0)
3:(0)
5
3:(3) 1 4 2
1:(1) 0
2:(0)
0:(0)
4:(0)

Sample Output

1
2

题意:

         Bob想保卫他的城镇,所以就安排士兵巡逻。因为兵力有限,就尽可能少的安排士兵,并使士兵能尽快到达邻近点。

思路:

         二分图最大匹配数 等于 这个图的最小点覆盖数

最小点覆盖——假如选了一个点就相当于 覆盖了以它为端点所有边,则需要选择最少的点图中覆盖所有边。(本题关键)

     

注意:

       本代码建立的是 无向图 ,所以 最大匹配 / 2

代码:

#include<map>
#include<queue>
#include<math.h>
#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
#define mem(a,b) memset(a,b,sizeof(a))
#define MM 2007
int line[MM][MM],book[MM],man[MM];
int n,m;
bool Find(int x)
{
    for(int i=0; i<n; i++)
    {
        if(line[x][i] && !book[i])
        {
            book[i]=1;
            if(!man[i] || Find(man[i]))
            {
                man[i]=x;
                return true;
            }
        }
    }
    return false;
}
int match()
{
    int ans=0;
    for(int i=0; i<n; i++)
    {
        mem(book,0);
        if(Find(i))
            ans++;
    }
    return ans/2;
}
int main()
{
    while(~scanf("%d",&n))
    {
        mem(line,0);
        mem(man,0);
        int jd,g,x;
        for(int i=1; i<=n; i++)
        {
            scanf("%d:(%d)",&jd,&g);
            for(int j=1;j<=g;j++)
            {
                scanf("%d",&x);
                line[jd][x]=line[x][jd]=1;  //建立无向图
            }
        }
        printf("%d\n",match());
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/team39/article/details/81262417
今日推荐