hdu 1711Number Sequence(KMP算法找第一次循环出现的位置)

Problem Description

Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.

Input

The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].

Output

For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

Sample Input

 

2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1

Sample Output

 

6 -1

Source

HDU 2007-Spring Programming Contest

Recommend

lcy   |   We have carefully selected several similar problems for you:  1358 3336 1686 3746 1251 

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int t[1000005];
int p[10005];
int f[10000005];
int f2[10000005];
int n,m;
void getfail(int*p,int *f)
{

    f[0]=f[1]=0;
 
    for(int i=1;i<m;i++)
    {int j=f[i];
        while(j&&p[i]!=p[j])

            j=f[j];
            f[i+1]=(p[i]==p[j])?j+1:0;
       
    }
}
int find(int*t,int*p,int*f)
{
    getfail(p,f);
    int j=0;
    for(int i=0;i<n;i++)
    {
        while(j&&t[i]!=p[j])
            j=f[j];
        if(t[i]==p[j])
            j++;
        if(j==m)
            return i-m+1+1;
    }
    return -1;
}
int  main()
{int k;
scanf("%d",&k);

while(k--)
{scanf("%d%d",&n,&m);

for(int i=0;i<n;i++)
    scanf("%d",&t[i]);
    t[n]=1e8;
    for(int i=0;i<m;i++)
    scanf("%d",&p[i]);
    p[m]=1e8;
    int ans=find(t,p,f);
    printf("%d\n",ans);



}
return 0;
}

猜你喜欢

转载自blog.csdn.net/sdauguanweihong/article/details/83894315