poj 2774 后缀数组 求最长连续公共子串长度

Long Long Message

Time Limit: 4000MS   Memory Limit: 131072K
Total Submissions: 35480   Accepted: 14218
Case Time Limit: 1000MS

Description

The little cat is majoring in physics in the capital of Byterland. A piece of sad news comes to him these days: his mother is getting ill. Being worried about spending so much on railway tickets (Byterland is such a big country, and he has to spend 16 shours on train to his hometown), he decided only to send SMS with his mother. 

The little cat lives in an unrich family, so he frequently comes to the mobile service center, to check how much money he has spent on SMS. Yesterday, the computer of service center was broken, and printed two very long messages. The brilliant little cat soon found out: 

1. All characters in messages are lowercase Latin letters, without punctuations and spaces. 
2. All SMS has been appended to each other – (i+1)-th SMS comes directly after the i-th one – that is why those two messages are quite long. 
3. His own SMS has been appended together, but possibly a great many redundancy characters appear leftwards and rightwards due to the broken computer. 
E.g: if his SMS is “motheriloveyou”, either long message printed by that machine, would possibly be one of “hahamotheriloveyou”, “motheriloveyoureally”, “motheriloveyouornot”, “bbbmotheriloveyouaaa”, etc. 
4. For these broken issues, the little cat has printed his original text twice (so there appears two very long messages). Even though the original text remains the same in two printed messages, the redundancy characters on both sides would be possibly different. 

You are given those two very long messages, and you have to output the length of the longest possible original text written by the little cat. 

Background: 
The SMS in Byterland mobile service are charging in dollars-per-byte. That is why the little cat is worrying about how long could the longest original text be. 

Why ask you to write a program? There are four resions: 
1. The little cat is so busy these days with physics lessons; 
2. The little cat wants to keep what he said to his mother seceret; 
3. POJ is such a great Online Judge; 
4. The little cat wants to earn some money from POJ, and try to persuade his mother to see the doctor :( 

Input

Two strings with lowercase letters on two of the input lines individually. Number of characters in each one will never exceed 100000.

Output

A single line with a single integer number – what is the maximum length of the original text written by the little cat.

Sample Input

yeshowmuchiloveyoumydearmotherreallyicannotbelieveit
yeaphowmuchiloveyoumydearmother

Sample Output

27

Source

POJ Monthly--2006.03.26,Zeyuan Zhu,"Dedicate to my great beloved mother."

求最长公共连续子串长度

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define maxn 200005
int len1,len2;
char s[maxn];
int sa[maxn];
int rank[maxn];
int height[maxn];
int t1[maxn],t2[maxn],c[maxn],n;
void build(int m)
{
    int i,*x=t1,*y=t2;
    for(int i=0;i<m;i++)
        c[i]=0;
    for(int i=0;i<n;i++)
        c[x[i]=s[i]]++;
    for(i=1;i<m;i++)
        c[i]+=c[i-1];
    for(i=n-1;i>=0;i--)
        sa[--c[x[i]]]=i;
    for(int k=1;k<=n;k<<=1)
    {
        int p=0;
        for(i=n-k;i<n;i++)
            y[p++]=i;
        for(i=0;i<n;i++)
            if(sa[i]>=k)
            y[p++]=sa[i]-k;
        for(i=0;i<m;i++)
            c[i]=0;
        for(i=0;i<n;i++)
            c[x[y[i]]]++;
        for(i=1;i<m;i++)
            c[i]+=c[i-1];
        for(i=n-1;i>=0;i--)
            sa[--c[x[y[i]]]]=y[i];
        swap(x,y);
        p=1;
        x[sa[0]]=0;
        for(i=1;i<n;i++)
            x[sa[i]]=y[sa[i]]==y[sa[i-1]]&&y[sa[i]+k]==y[sa[i-1]+k]?p-1:p++;
        if(p>=n)
            break;
        m=p;
    }

}
void buildheight()
{
    int i,j,k=0;
    for(i=0;i<n;i++)
        rank[sa[i]]=i;
    for(i=0;i<n;i++)
    {
        if(k)
            k--;
        j=sa[rank[i]-1];
        while(s[i+k]==s[j+k])
            k++;
        height[rank[i]]=k;
    }
}
int solve()
{
    int ans=0;
    for(int i=2;i<n;i++)

    {
        int a1=sa[i-1];
        int a2=sa[i];
        if(a1>a2)
            swap(a1,a2);
        if(a1>=0&&a1<=len1-1&&a2>=len1+1&&a2<=len1+len2)
            ans=max(ans,height[i]);
    }
    return ans;
}
int main()
{
    scanf("%s",s);
    len1=strlen(s);
    s[len1]=1;
    scanf("%s",s+len1+1);

    len2=strlen(s)-len1-1;
    n=len1+len2+2;
    s[len1+len2+1]=0;
    build(128);
    buildheight();
    printf("%d\n",solve());
    return 0;
}

将两个串连在一起,然后求height数组

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define maxn 200005
int len1,len2;
char s[maxn];
int sa[maxn];
int rank[maxn];
int height[maxn];
int t1[maxn],t2[maxn],c[maxn],n;
void build(int m)
{
    int i,*x=t1,*y=t2;
    for(int i=0;i<m;i++)
        c[i]=0;
    for(int i=0;i<n;i++)
        c[x[i]=s[i]]++;
    for(i=1;i<m;i++)
        c[i]+=c[i-1];
    for(i=n-1;i>=0;i--)
        sa[--c[x[i]]]=i;
    for(int k=1;k<=n;k<<=1)
    {
        int p=0;
        for(i=n-k;i<n;i++)
            y[p++]=i;
        for(i=0;i<n;i++)
            if(sa[i]>=k)
            y[p++]=sa[i]-k;
        for(i=0;i<m;i++)
            c[i]=0;
        for(i=0;i<n;i++)
            c[x[y[i]]]++;
        for(i=1;i<m;i++)
            c[i]+=c[i-1];
        for(i=n-1;i>=0;i--)
            sa[--c[x[y[i]]]]=y[i];
        swap(x,y);
        p=1;
        x[sa[0]]=0;
        for(i=1;i<n;i++)
            x[sa[i]]=y[sa[i]]==y[sa[i-1]]&&y[sa[i]+k]==y[sa[i-1]+k]?p-1:p++;
        if(p>=n)
            break;
        m=p;
    }

}
void buildheight()
{
    int i,j,k=0;
    for(i=0;i<n;i++)
        rank[sa[i]]=i;
    for(i=0;i<n;i++)
    {
        if(k)
            k--;
        j=sa[rank[i]-1];
        while(s[i+k]==s[j+k])
            k++;
        height[rank[i]]=k;
    }
}
int solve()
{
    int ans=0;
    for(int i=2;i<n;i++)

    {
        int a1=sa[i-1];
        int a2=sa[i];
        if(a1>a2)
            swap(a1,a2);
        if(a1>=0&&a1<=len1-1&&a2>=len1+1&&a2<=len1+len2)
            ans=max(ans,height[i]);
    }
    return ans;
}
int main()
{
    scanf("%s",s);
    len1=strlen(s);
    s[len1]=1;
    scanf("%s",s+len1+1);

    len2=strlen(s)-len1-1;
    n=len1+len2+2;
    s[len1+len2+1]=0;
    build(128);
    buildheight();
    printf("%d\n",solve());
    return 0;
}

猜你喜欢

转载自blog.csdn.net/sdauguanweihong/article/details/84166281
今日推荐