hdu1028(dp 或母函数)

Ignatius and the Princess III

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 24446    Accepted Submission(s): 16980


Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:
  N=a[1]+a[2]+a[3]+...+a[m];
  a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
  4 = 4;
  4 = 3 + 1;
  4 = 2 + 2;
  4 = 2 + 1 + 1;
  4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
 

Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
 

Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
 

Sample Input
 
  
4 10 20
 

Sample Output
 
  
5 42 627
 

Author
Ignatius.L
 

Recommend
We have carefully selected several similar problems for you:   1171  1085  1398  2152  1709 
 

Statistic |  Submit |  Discuss

题意:给你一个数n,问n有多少总凑法让这些数的和等于n

例如 3=1+1+1=1+2=3 有三种

题解:

1.母函数模板(第二类问题)

2.dp

显然凑数的时候大的数方法会覆盖小的数,那么凑大的数就可以往前找

例如凑5每次加一的话就往4加,加二就往3加

#include <iostream>
using namespace std;
int main (void)
{
int i,j,d[125]={1};//d[0]=1,其他自动初始化为0 
                       
for(i=1;i<121;i++) //从小到大加不会重复,从1往后加 
   for(j=i;j<121;j++) //从能+i的最小的那个数开始+n
       d[j]+=d[j-i];//加到自身就是加d[0] ( =1 ) 
while(cin>>i)
cout<<d[i]<<endl;
return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41603898/article/details/80266325