Sorting It All Out (拓扑排序是否有环是否严格有序)

Sorting It All Out

An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to largest. For example, the sorted sequence A, B, C, D implies that A < B, B < C and C < D. in this problem, we will give you a set of relations of the form A < B and ask you to determine whether a sorted order has been specified or not.
Input
Input consists of multiple problem instances. Each instance starts with a line containing two positive integers n and m. the first value indicated the number of objects to sort, where 2 <= n <= 26. The objects to be sorted will be the first n characters of the uppercase alphabet. The second value m indicates the number of relations of the form A < B which will be given in this problem instance. Next will be m lines, each containing one such relation consisting of three characters: an uppercase letter, the character “<” and a second uppercase letter. No letter will be outside the range of the first n letters of the alphabet. Values of n = m = 0 indicate end of input.
Output
For each problem instance, output consists of one line. This line should be one of the following three:

Sorted sequence determined after xxx relations: yyy…y.
Sorted sequence cannot be determined.
Inconsistency found after xxx relations.

where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy…y is the sorted, ascending sequence.
Sample Input
4 6
A<B
A<C
B<C
C<D
B<D
A<B
3 2
A<B
B<A
26 1
A<Z
0 0
Sample Output
Sorted sequence determined after 4 relations: ABCD.
Inconsistency found after 2 relations.
Sorted sequence cannot be determined.

题意:给定一组字母的大小关系判断它们是否能组成唯一的拓扑序列。
思路

  1. 先判断是否有环(一旦发现找不到入度为0的结点,立即return)

  2. 再判断是否严格有序(当每一步能且只能找到一个度为0的结点,则输出)

  3. 最后才能判断是否能得出结果(当发现无法确定时,并不能立即return,因为还需要判断是否有环)。

当发现多个结点的度为0时,则不是严格有序。当发现没有结点入度为0时,则有环
必须遍历完整个图才能知道是否有环!!!

注意输出中的标点符号

#include<cstdio>
#include<cstring>
using namespace std;
int n,m,ok;
int map[30][30];//邻接矩阵存图
int deg[30];//入度
char s[10];
int q[30];//模拟队列存储要输出的序列
int TP(){
	int cnt=0;//队列中最后一个元素的下标(解空间中零入度顶点的个数)
	int temp[30];//对顶点入度备份
	int pos;//记录一个零入度顶点位置
	int m;//零入度顶点的个数
	int flag=1;//flag==1有序  flag==-1不能确定
	for(int i=1;i<=n;i++){
		temp[i]=deg[i];//备份 
	} 
	for(int i=1;i<=n;i++){//遍历n遍,必须把图全部遍历完
		m=0;
		for(int j=1;j<=n;j++){//查找零入度顶点的个数
			if(temp[j]==0){
				m++;
				pos=j;//记录一个零入度顶点的位置
			}
		}
		if(m==0){       //有环 
			return 0;
		}
		if(m>1){//无序
			flag=-1;//不能立即退出,还要继续遍历判断是否有环
		} 
		q[cnt++]=pos;//零入度顶点入度
		temp[pos]=-1;//将零入度顶点的入度置为-1
		for(int j=1;j<=n;j++){//删除已pos为起点的边
			if(map[pos][j]==1)
			temp[j]--;//相应顶点的入度减1;
		}
	}
	return flag;
}
int main(){
	while(scanf("%d%d",&n,&m)){
		if(n==0&&m==0) break;
		memset(map,0,sizeof(map));
		memset(deg,0,sizeof(deg));
		ok=0;
		for(int i=1;i<=m;i++){
			scanf("%s",s);
			if(ok) continue;//ok!=0时,已得出结果,将不考虑后面输入
			int u=s[0]-'A'+1;
			int v=s[2]-'A'+1;
			map[u][v]=1;
			deg[v]++;
			int flag=TP();
			if(flag==0){//有环
				printf("Inconsistency found after %d relations.\n",i);//注意标点符号
				ok=1;
			}
			else if(flag==1){//有序
				printf("Sorted sequence determined after %d relations: ",i);
				for(int j=0;j<n;j++){
					printf("%c",q[j]+'A'-1);
				}
				printf(".\n");//注意标点符号
				ok=1;
			}
		}
		if(!ok){//无法得出结果
			printf("Sorted sequence cannot be determined.\n");//注意标点符号
		}	
	}
	return 0;
}

注意输出中的标点符号

猜你喜欢

转载自blog.csdn.net/qq_42936517/article/details/84349173