1057 Stack (30 分)PAT (Advanced Level) Practice

Stack is one of the most fundamental data structures, which is based on the principle of Last In First Out (LIFO). The basic operations include Push (inserting an element onto the top position) and Pop (deleting the top element). Now you are supposed to implement a stack with an extra operation: PeekMedian -- return the median value of all the elements in the stack. With Nelements, the median value is defined to be the (N/2)-th smallest element if N is even, or ((N+1)/2)-th if N is odd.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤10​5​​). Then N lines follow, each contains a command in one of the following 3 formats:

Push key
Pop
PeekMedian

where key is a positive integer no more than 10​5​​.

Output Specification:

For each Push command, insert key into the stack and output nothing. For each Pop or PeekMedian command, print in a line the corresponding returned value. If the command is invalid, print Invalid instead.

Sample Input:

17
Pop
PeekMedian
Push 3
PeekMedian
Push 2
PeekMedian
Push 1
PeekMedian
Pop
Pop
Push 5
Push 4
PeekMedian
Pop
Pop
Pop
Pop

Sample Output:

Invalid
Invalid
3
2
2
1
2
4
4
5
3
Invalid

 题目大意:现请你实现一种特殊的堆栈,它多了一种操作叫“查中值”,即返回堆栈中所有元素的中值。对于N个元素,若N是偶数,则中值定义为第N/2个最小元;若N是奇数,则中值定义为第(N+1)/2个最小元。

纯模拟一下,超时又爆栈,我就不想多说什么了

#include<iostream>
#include<string>
#include<cstdio>
#include<algorithm>
#include<map>
using namespace std;
 
int n,d;;
int A[10005],B[10005];
 
int select(int num)
{
	for(int i=1;i<=d;i++) B[i]=A[i];
	sort(B+1,B+d+1);
	return B[num];
}
 
void process()
{
	char operate[1000];
	scanf("%s",operate);
	string s=operate;
 
	if(s=="Pop")
	{
		if(d==0)
			printf("Invalid\n");
		else 
		{
			printf("%d\n",A[d]);
			d--;
		}
	}
	else if(s=="PeekMedian")
	{
		if(d==0)
			printf("Invalid\n");
		else
		{
			int num;
			if(d%2==0) num=d/2;
			else
				num=(d+1)/2;
			printf("%d\n",select(num));
		}
	}
	else if(s=="Push")
	{
		int b;
		scanf("%d",&b);
		A[++d]=b;
	}
}
 
int main()
{
	//freopen("1.txt","r",stdin);
	while(scanf("%d",&n)!=EOF)
	{
		d=0;
		for(int i=0;i<n;i++) 
			process();
	}
	return 0;
}

树状数组写法

#include <iostream>
#include <stack>
#define lowbit(i) ((i) & (-i))
const int maxn = 100010;
using namespace std;
int c[maxn];
//这个是用来计数每个元素出现的次数,比如push 3,那么就是3多了一个。
//表示≤当前下标的有几个。
stack<int> s;
void update(int x, int v) 
{
	while(x<maxn)
	{
		c[x]+=v;
		x+=lowbit(x);
	}
}
int getsum(int x) 
{
    int sum = 0;    
    while(x>0)
	{
		sum+=c[x];
		x-=lowbit(x);
	}
    return sum;
}
void PeekMedian() {
    int left = 1, right = maxn, mid, k = (s.size() + 1) / 2;
    while(left < right) {//使用二分法查找。
        mid = (left + right) / 2;
        if(getsum(mid) >= k)
            right = mid;
        else
            left = mid + 1;
    }
    printf("%d\n", left);
}
int main() {
    int n, temp;
    scanf("%d", &n);
    char str[15];
    for(int i = 0; i < n; i++) {
        scanf("%s", str);
        if(str[1] == 'u') {
            scanf("%d", &temp);
            s.push(temp);
            update(temp, 1);
        } else if(str[1] == 'o') {
            if(!s.empty()) {
                update(s.top(), -1);
                printf("%d\n", s.top());
                s.pop();
            } else {
                printf("Invalid\n");
            }
        } else {
            if(!s.empty())
                PeekMedian();
            else
                printf("Invalid\n");
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/mlm5678/article/details/83247637