杭电1004

Problem Description

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you. 

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.
A test case with N = 0 terminates the input and this test case is not to be processed.

Output

For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input

5

green

red

blue

red

red

3

pink

orange

pink

0

Sample Output

red

pink

这道题在考验字符串的比较找出一群字符串中出现最多的字符串。

#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;
char a[1000][16];//首先利用二维数组对输入的字符串进行存储
int b[1000];
int main()
{
    int n,i,max,j;
    while(scanf("%d",&n)!=EOF&&n!=0)
    {
        max=0;//注意归0的小问题
        for(i=0;i<n;i++)
         {
             scanf("%s",a[i]);//存储
         }
         for(i=0;i<n;i++)
         {
             b[i]=0;
             for(j=i+1;j<n;j++)
             {
                 if(strcmp(a[i],a[j])==0)//进行比较
                 {
                     b[i]++;
                 }
             }
             if(b[i]>max)
                max=b[i];
         }
         for(i=0;i<n;i++)
         {
             if(b[i]==max)//利用下标输出最多的字符串
                printf("%s\n",a[i]);
         }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/acm147258369/article/details/84573179