poj-1463 K - Strategic game (树形DP)

Bob enjoys playing computer games, especially strategic games, but sometimes he cannot find the solution fast enough and then he is very sad. Now he has the following problem. He must defend a medieval city, the roads of which form a tree. He has to put the minimum number of soldiers on the nodes so that they can observe all the edges. Can you help him? 

Your program should find the minimum number of soldiers that Bob has to put for a given tree. 

For example for the tree: 


the solution is one soldier ( at the node 1).

Input

The input contains several data sets in text format. Each data set represents a tree with the following description: 


  • the number of nodes 
  • the description of each node in the following format 
    node_identifier:(number_of_roads) node_identifier1 node_identifier2 ... node_identifiernumber_of_roads 
    or 
    node_identifier:(0) 


The node identifiers are integer numbers between 0 and n-1, for n nodes (0 < n <= 1500);the number_of_roads in each line of input will no more than 10. Every edge appears only once in the input data.

Output

The output should be printed on the standard output. For each given input data set, print one integer number in a single line that gives the result (the minimum number of soldiers). An example is given in the following:

Sample Input

4
0:(1) 1
1:(2) 2 3
2:(0)
3:(0)
5
3:(3) 1 4 2
1:(1) 0
2:(0)
0:(0)
4:(0)

Sample Output

1
2

题意:n个点,n-1条边,问需要多少个士兵可以监督所有的边。

树形DP:

建立一个树,dp[1][u]+=min(dp[1][v],dp[0][v])选择此点,子节点可选可不选。

                     dp[0][u]+=dp[1][v]不选此点,必选子节点。

#include<stdio.h>
#include<queue>
#include<stack>
#include<vector>
#include<string.h>
#include<algorithm>
using namespace std;
const int N=2000;
int head[N];
int tot,n,m;
int dis[N];
int flag[N];
int dp[2][N];
struct node
{
    int u,v,next;
} g[N];
void add(int u,int v)
{
    g[tot].v=v;
    g[tot].next=head[u];
    head[u]=tot++;
}
void init()
{
    tot=0;
    memset(head,-1,sizeof(head));
    memset(flag,0,sizeof(flag));
    for(int i=0;i<n;i++)
        dp[1][i]=1,dp[0][i]=0;
    memset(g,0,sizeof(g));
}
void dfs(int u)
{
    for(int i=head[u];~i;i=g[i].next)
    {
        int v=g[i].v;
        dfs(v);
        dp[1][u]+=min(dp[1][v],dp[0][v]);
        dp[0][u]+=dp[1][v];
    }
}
int main()
{
    while(~scanf("%d",&n))
    {
        init();
        for(int i=1;i<=n;i++)
        {
            int a,b,c;
            scanf("%d:(%d)",&a,&b);
            for(int j=0;j<b;j++)
            {
                scanf("%d",&c);
                add(a,c);
                flag[c]++;
            }
        }
        int oo;
        for(int i=0;i<n;i++)
        {
            if(!flag[i])
            {
                oo=i;
                dfs(i);
                break;
            }
        }
        printf("%d\n",min(dp[0][oo],dp[1][oo]));
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Kuguotao/article/details/84348646