HDU-Wooden Sticks(贪心)

Wooden Sticks

There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:

(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup.

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.

Output

The output should contain the minimum setup time in minutes, one per line.

Sample Input

3 
5 
4 9 5 2 2 1 3 5 1 4 
3 
2 2 1 1 2 2 
3 
1 3 2 2 3 1

Sample Output

2
1
3

题目链接:

http://acm.hdu.edu.cn/showproblem.php?pid=1051

 题意描述:

给你n组区间,存在包含关系的区间为相同区间,问共有多少组不同的区间。

解题思路:

先把这些区间存到结构体中,然后对区间的首端进行从小到大排序,然后再在这n个区间中从前往后遍历,只要这个区间未被遍历过,并且该区间的尾端大于与之比较的区间的尾端(记得更新区间,每比较一次区间,该区间就要被更新,也就是程序中的q),那么就证明这两个区间属于相同区间。

程序代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct data{
	int a;
	int b;
}s[5010];
int book[5010];

int cmp(data x,data y);

int main()
{
	int T,n,i,j,sum,q;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d",&n);
		sum=n;
		for(i=0;i<n;i++)
			scanf("%d%d",&s[i].a,&s[i].b);
		sort(s,s+n,cmp);
		memset(book,0,sizeof(book));
		for(i=0;i<n-1;i++)
		{
			q=s[i].b;
			if(book[i]==0)
				for(j=i+1;j<n;j++)
				{
					if(book[j]==0&&s[j].b>=q)
					{
						q=s[j].b;
						book[j]=1;
						sum--;
					}
				}
		}
		printf("%d\n",sum);
	}
	return 0;
}
int cmp(data x,data y)
{
	if(x.a!=y.a)
		return x.a<y.a;
	return x.b<y.b;
}

猜你喜欢

转载自blog.csdn.net/HeZhiYing_/article/details/84850054