HDU-2101 A + B Problem Too(语法练习题)

A + B Problem Too

Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 20917 Accepted Submission(s): 15417

Problem Description
This problem is also a A + B problem,but it has a little difference,you should determine does (a+b) could be divided with 86.For example ,if (A+B)=98,you should output no for result.

Input
Each line will contain two integers A and B. Process to end of file.

Output
For each case, if(A+B)%86=0,output yes in one line,else output no in one line.

Sample Input
1 1
8600 8600

Sample Output
no
yes

Source
HDU 2007-6 Programming Contest

问题简述:

  输入两个数,如果两数之和为86的倍数则输出"yes",否则输出"no"。

问题分析:

  求和后取余判断即可。

程序说明:

  使用c++标准输入输入流。

程序实现:

#include<iostream>
using namespace std;

int main()
{
    int a,b;
    while(cin>>a>>b)
    {
        if((a+b)%86==0) cout<<"yes"<<endl;
        else cout<<"no"<<endl;
    }
}

猜你喜欢

转载自blog.csdn.net/weixin_43939327/article/details/84844850