线性表——两个有序链表序列的合并

已知两个非降序链表序列S1与S2,设计函数构造出S1与S2合并后的新的非降序链表S3。

输入格式:
输入分两行,分别在每行给出由若干个正整数构成的非降序序列,用−1表示序列的结尾(−1不属于这个序列)。数字用空格间隔。

输出格式:
在一行中输出合并后新的非降序链表,数字间用空格分开,结尾不能有多余空格;若新链表为空,输出NULL。

输入样例:
1 3 5 -1
2 4 6 8 10 -1
输出样例:
1 2 3 4 5 6 8 10

#include <cstdio>
#include <iostream>
#include <cstring>
#include <string>
#include <malloc.h>
#include <math.h>
using namespace std;

typedef struct LNode{
    int data;
    LNode *next;
}LNode, *Linklist;

void Init(Linklist &L)
{
    LNode *tmp;
    tmp = (Linklist)malloc(sizeof(LNode));
    tmp->next = NULL;
    L = tmp;
}

void Add(Linklist &L)
{
    int n;
    LNode *tmp, *p;
    tmp = L;
    while(~scanf("%d", &n))
    {
        if(n == -1) break;
        p = (Linklist)malloc(sizeof(LNode));
        p->data = n;
        p->next = NULL;
        tmp->next = p;
        tmp= p;
    }
}
Linklist componed(Linklist &L1, Linklist &L2)
{
    Linklist L;
    Init(L);
    LNode *tmp1, *tmp2, *tmp;
    tmp = L;
    tmp1 = L1->next;
    tmp2 = L2->next;
    while(tmp1 != NULL && tmp2 != NULL)
    {
        if(tmp1->data <= tmp2->data)
        {
            tmp->next = tmp1;
            tmp = tmp1;
            //printf("%d\n", tmp->data);
            tmp1 = tmp1->next;
        }
        else
        {
            tmp->next = tmp2;
            tmp = tmp2;
            //printf("%d\n", tmp->data);
            tmp2 = tmp2->next;
        }
    }
    while(tmp1 != NULL)
    {
        tmp->next = tmp1;
        tmp = tmp1;
        tmp1 = tmp1->next;
    }
    while(tmp2 != NULL)
    {
        tmp->next = tmp2;
        tmp = tmp2;
        tmp2 = tmp2->next;
    }
    return L;
}
void print(Linklist L)
{
    int flag = 0;
    LNode *tmp = L->next;
    while(tmp != NULL)
    {
        if(flag) printf(" ");
        flag = 1;
        printf("%d", tmp->data);
        tmp = tmp->next;
    }
    printf("\n");
}
int main()
{
    Linklist L1, L2, L3;
    Init(L1);
    Init(L2);
    //Init(L3);
//    Add(L1);
//    Add(L2);
    print(L1);
    print(L2);
    L3 = componed(L1, L2);
    print(L3);
}

猜你喜欢

转载自blog.csdn.net/weixin_42618424/article/details/85042286