【笨方法学PAT】1133 Splitting A Linked List (25 分)

版权声明:欢迎转载,请注明来源 https://blog.csdn.net/linghugoolge/article/details/84624051

一、题目

Given a singly linked list, you are supposed to rearrange its elements so that all the negative values appear before all of the non-negatives, and all the values in [0, K] appear before all those greater than K. The order of the elements inside each class must not be changed. For example, given the list being 18→7→-4→0→5→-6→10→11→-2 and K being 10, you must output -4→-6→-2→7→0→5→10→18→11.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤10​5​​) which is the total number of nodes, and a positive K (≤10​3​​). The address of a node is a 5-digit nonnegative integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer in [−10​5​​,10​5​​], and Next is the position of the next node. It is guaranteed that the list is not empty.

Output Specification:

For each case, output in order (from beginning to the end of the list) the resulting linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 9 10
23333 10 27777
00000 0 99999
00100 18 12309
68237 -6 23333
33218 -4 00000
48652 -2 -1
99999 5 68237
27777 11 48652
12309 7 33218

Sample Output:

33218 -4 68237
68237 -6 48652
48652 -2 12309
12309 7 00000
00000 0 99999
99999 5 23333
23333 10 00100
00100 18 27777
27777 11 -1

二、题目大意

给定链表,按照特定顺序排序。

三、考点

链表

四、注意

1、有的节点可能不在链表内;

2、输出之前整合在一起,可以减少很多判断。

五、代码

#include<iostream>
#include<vector>
#define N 100005
using namespace std;
struct node {
	int add;
	int val;
	int next;
};
vector<node> vec(N), v, v1, v2, v0;
int main() {
	//read
	int add, n, k;
	cin >> add >> n >> k;
	for (int i = 0; i < n; ++i) {
		int a;
		node nd;
		cin >> a >> nd.val >> nd.next;
		nd.add = a;
		vec[a] = nd;
	}

	//clear
	while (add != -1) {
		v.push_back(vec[add]);
		add = vec[add].next;
	}
	
	//sort
	for(int i=0;i<v.size();++i){
		if (v[i].val < 0)
			v0.push_back(v[i]);
		else if(v[i].val <= k) 
			v1.push_back(v[i]);
		else
			v2.push_back(v[i]);
	}

	//merge
	v.clear();
	for (int i = 0; i < v0.size(); ++i)
		v.push_back(v0[i]);
	for (int i = 0; i < v1.size(); ++i)
		v.push_back(v1[i]);
	for (int i = 0; i < v2.size(); ++i)
		v.push_back(v2[i]);

	if (v.size() == 0) {
		cout << -1 << endl;
		return 0;
	}

	//output
	for (int i = 0; i < v.size() - 1; ++i) {
		printf("%05d %d %05d\n", v[i].add, v[i].val, v[i + 1].add);
	}
	printf("%05d %d -1\n", v[v.size() - 1].add, v[v.size() - 1].val);
	

	system("pause");
	return 0;
}

猜你喜欢

转载自blog.csdn.net/linghugoolge/article/details/84624051