Doubles

As part of an arithmetic competency program, your students will be given randomly generated lists of from 2 to 15 unique positive integers and asked to determine how many items in each list are twice some other item in the same list. You will need a program to help you with the grading. This program should be able to scan the lists and output the correct answer for each one. For example, given the list

1 4 3 2 9 7 18 22

your program should answer 3, as 2 is twice 1, 4 is twice 2, and 18 is twice 9.


Input

The input file will consist of one or more lists of numbers. There will be one list of numbers per line. Each list will contain from 2 to 15 unique positive integers. No integer will be larger than 99. Each line will be terminated with the integer 0, which is not considered part of the list. A line with the single number -1 will mark the end of the file. The example input below shows 3 separate lists. Some lists may not contain any doubles.


Output

The output will consist of one line per input list, containing a count of the items that are double some other item.


Sample Input

1 4 3 2 9 7 18 22 0
2 4 8 10 0
7 5 11 13 1 3 0
-1


Sample Output

3
2

0



#include<bits/stdc++.h>
using namespace std;
int s[105];
int b[105];
int changdu;
int main()
{
    while(1)
    {
        int num = 0;
        for(int i=0; ; i++)///循环输入
        {
            scanf("%d",&s[i]);
            b[i] = s[i];///赋值给第二个数组
            changdu = i;///记录长度
            if(s[i] == 0)
            {
                break;///如果遇到0表示结尾,结束
            }
            if(s[i] == -1)
            {
                return 0;///遇到-1,表示程序结束
            }
        }
        sort(b,b+changdu);///对b数组排序(从小到大)
        for(int i=changdu-1; i>0; i--)///将b数组逆序枚举
        {
            for(int j=0; j<changdu; j++)///枚举s数组,查找有否有2倍的关系
            {
                if(b[i] == 2*s[j])
                {
                   //printf("%d %d\n",s[j],b[i]);
                    num++;///如果有数量就+1
                }
            }
        }
        printf("%d\n",num);
    }
}

猜你喜欢

转载自blog.csdn.net/wonder__/article/details/79746991