1144 The Missing Number(20 分)(C++)

Given N integers, you are supposed to find the smallest positive integer that is NOT in the given list.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​5​​). Then N integers are given in the next line, separated by spaces. All the numbers are in the range of int.

Output Specification:

Print in a line the smallest positive integer that is missing from the input list.

Sample Input:

10
5 -25 9 6 1 3 4 2 5 17

Sample Output:

7

设一个数组记录出现过的小于10^5的正数

#include<iostream>
#include<vector>
#include<cstdio>
using namespace std;
std::vector<int> v(1000000,0);
int main(){
    int n;
    scanf("%d",&n);
    for(int i=0;i<n;i++){
        int x;
        scanf("%d",&x);
        if(x>0&&x<1000000)
         v[x]=1;
    }
    for(int i=1;i<v.size();i++){
        if(v[i]==0){
            cout<<i;
            break;
        }
   }
}

猜你喜欢

转载自blog.csdn.net/qq_41562704/article/details/82502868