hdu_problem_2001_计算两点间的距离

/*
*
*Problem Description
*输入两点坐标(X1,Y1),(X2,Y2),计算并输出两点间的距离。
* 
*
*Input
*输入数据有多组,每组占一行,由4个实数组成,分别表示x1,y1,x2,y2,数据之间用空格隔开。
*
*
*Output
*对于每组输入数据,输出一行,结果保留两位小数。
*
*
*Sample Input
*0 0 0 1
*0 1 1 0
* 
*
*Sample Output
*1.00
*1.41
* 
*
*Author
*lcy
* 
*
*Source
*C语言程序设计练习(一) 
* 
*
*Recommend
*JGShining
*
*/#include<iostream>
using namespace std;
float distance(float x1, float y1, float x2, float y2) {
 return sqrt((x1 - x2)*(x1 - x2) + (y1 - y2)*(y1 - y2));
}
float sqrt(int num) {
 float temp;
 for (temp = 0; temp*temp <= num; temp+=1);
 temp-=1;
 for (int i = 0; i < 3; i++) {
  temp = (temp + num / temp) / 2;
 }
 return temp;
}
int main() {
 float x1, y1, x2, y2;
 while (cin >> x1 >> y1 >> x2 >> y2) {
  printf("%.2f\n", distance(x1,y1,x2,y2));
 }
 system("pause");
 return 0;
}

猜你喜欢

转载自blog.csdn.net/CoderMaximum/article/details/86136258
今日推荐