H - S-Nim

H - S-Nim

Arthur and his sister Caroll have been playing a game called Nim for some time now. Nim is played as follows:


The starting position has a number of heaps, all containing some, not necessarily equal, number of beads.

The players take turns chosing a heap and removing a positive number of beads from it.

The first player not able to make a move, loses.


Arthur and Caroll really enjoyed playing this simple game until they recently learned an easy way to always be able to find the best move:


Xor the number of beads in the heaps in the current position (i.e. if we have 2, 4 and 7 the xor-sum will be 1 as 2 xor 4 xor 7 = 1).

If the xor-sum is 0, too bad, you will lose.

Otherwise, move such that the xor-sum becomes 0. This is always possible.


It is quite easy to convince oneself that this works. Consider these facts:

The player that takes the last bead wins.

After the winning player's last move the xor-sum will be 0.

The xor-sum will change after every move.


Which means that if you make sure that the xor-sum always is 0 when you have made your move, your opponent will never be able to win, and, thus, you will win.

Understandibly it is no fun to play a game when both players know how to play perfectly (ignorance is bliss). Fourtunately, Arthur and Caroll soon came up with a similar game, S-Nim, that seemed to solve this problem. Each player is now only allowed to remove a number of beads in some predefined set S, e.g. if we have S =(2, 5) each player is only allowed to remove 2 or 5 beads. Now it is not always possible to make the xor-sum 0 and, thus, the strategy above is useless. Or is it?

your job is to write a program that determines if a position of S-Nim is a losing or a winning position. A position is a winning position if there is at least one move to a losing position. A position is a losing position if there are no moves to a losing position. This means, as expected, that a position with no legal moves is a losing position.

Input

Input consists of a number of test cases.
For each test case: The rst line contains a number k (0 < k <= 100) describing the size of S, followed by k numbers si (0 < si <= 10000) describing S. The second line contains a number m (0 < m <= 100) describing the number of positions to evaluate. The next m lines each contain a number l (0 < l <= 100) describing the number of heaps and l numbers hi (0 <= hi <= 10000) describing the number of beads in the heaps.
The last test case is followed by a 0 on a line of its own.

Output

For each position:
If the described position is a winning position print a 'W'.
If the described position is a losing position print an 'L'.
Print a newline after each test case.

Sample Input

2 2 5
3
2 5 12
3 2 4 7
4 2 3 7 12
5 1 2 3 4 5
3
2 5 12
3 2 4 7
4 2 3 7 12
0

Sample Output

LWW
WWL

题目大意:

给定 K个数,表示对应的操作集的长度

接着是操作集合  S

再给定 m次要评估的游戏

每次游戏都会给定 堆的个数 L

然后给定一个堆集合 heap

思路:

求出每个堆的SG ,再对每个堆进行异或运算,若为0 则,会失败。反之胜利。

具体思路见 :https://blog.csdn.net/qq_40507857/article/details/81277606

#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;

//heap number
const int MAXN = 10010;
//k number
const int MAXK = 110;
bool p[MAXN];//标记

int calSG(int *S,int Snum,int max,int *SG,int maxHeap){

    //bool *p = new bool[max+1];  // time limit  this way
    //fill(p,p+max+1,false);   // time limit  this way
    memset(p,false,sizeof(p));
    for(int i=0;i<maxHeap;i++){

        for(int j=0;j<Snum&&i>=S[j];j++){
            p[SG[i-S[j]]] = true;
        }

        for(int k=0;k<=max;k++){
            if(p[k]==false){
                SG[i] = k;
                break;
            }
        }

        memset(p,false,sizeof(p));
    }

    return 0;
}

int main(){


    int S[MAXK];
    int heap[MAXK];
    int SG[MAXN];

    int Snum;

    while(scanf("%d",&Snum)!=EOF){
        if(Snum==0) break;

        int max=-1;
        for(int i=0;i<Snum;i++){
            scanf("%d",&S[i]);
            if(max<S[i]){
                max = S[i];
            }
        }

        sort(S,S+Snum);

        calSG(S,Snum,max,SG,MAXN);

        int M;
        scanf("%d",&M);
        for(int i=0;i<M;i++){

            int L;
            scanf("%d",&L);

            int sg =0;
            for(int j=0;j<L;j++){
                scanf("%d",&heap[j]);
                sg=sg^SG[heap[j]];
            }

            if(sg==0){
                printf("L");
            }else{
                printf("W");
            }

        }
        printf("\n");
    }

    return 0;
}

注意:

//bool *p = new bool[max+1];  // time limit  this way
    //fill(p,p+max+1,false);   // time limit  this way

在方法中用动态申请地址的方法会超时,所以还是再最开始申请静态并结合memset(p,false,sizeof(p));的方法会减少时间复杂度

猜你喜欢

转载自blog.csdn.net/Willen_/article/details/85212875