Periodic Strings

A character string is said to have period k if it can be formed by concatenating one or more repetitions
of another string of length k. For example, the string ”abcabcabcabc” has period 3, since it is formed
by 4 repetitions of the string ”abc”. It also has periods 6 (two repetitions of ”abcabc”) and 12 (one
repetition of ”abcabcabcabc”).
Write a program to read a character string and determine its smallest period.
Input
The first line oif the input file will contain a single integer N indicating how many test case that your
program will test followed by a blank line. Each test case will contain a single character string of up
to 80 non-blank characters. Two consecutive input will separated by a blank line.
Output
An integer denoting the smallest period of the input string for each input. Two consecutive output are
separated by a blank line.
Sample Input
1
HoHoHo
Sample Output
2
代码
#include<stdio.h>
#include<string.h>
int main()
{
int n;
while(scanf("%d",&n)!= EOF)
{
char str[81];
for(int i=0;i<n;i++)
{
scanf("%s",str);
int len=strlen(str);
for(int j=1,k;j<=len;j++)
{
if(len%j0)
{
for(k=j;k<len;k++)
{
if(str[k]!=str[k%j])
break;
}
if(k
len)
{
printf("%d\n",j);
break;
}
}
}
if(i!=n-1)
printf("\n");
}
}
}

猜你喜欢

转载自blog.csdn.net/weixin_43797508/article/details/86258631
今日推荐