算法设计课第八周作业

8. Greatest Common Divisors

Description

A common divisor for two positive numbers is a number which both numbers are divisible by. It’s easy to calculate the greatest common divisor between tow numbers. But your teacher wants to give you a harder task, in this task you have to find the greatest common divisor d between two integers a and b that is in a given range from low to high (inclusive), i.e. low<=d<=high. It is possible that there is no common divisor in the given range.

Input

The first line contains an integer T (1<=T<=10)- indicating the number of test cases.

For each case, there are four integers a, b, low, high (1<=a,b<=1000,1<=low<=high<=1000) in one line.

Output

For each case, print the greatest common divisor between a and b in given range, if there is no common divisor in given range, you should print “No answer”(without quotes).

Sample Input

3 
9 27 1 5 
9 27 10 11 
9 27 9 11 

Sample Output

3
No answer
9

思路

直接遍历那个区间中的数字,判断是否既能除以A又能除以B。

代码

#include<iostream>

using namespace std;

int main()
{
    int times;
    cin >> times;
    while(times--)
    {
        int a, b, low, high;

        cin >> a >> b >> low >> high;

        bool result;
        int divisor;

        for(divisor = high; divisor >= low; divisor--)
        {
            if(a % divisor == 0 && b % divisor == 0) {
			result = true; 
			break;
			}
            result = false;
        }

        if(result) cout << divisor << endl;
        else cout << "No answer" << endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_38873581/article/details/86518348
今日推荐