PAT (Advanced Level) Practice A1095 Cars on Campus (30 分)(C++)(甲级)(排序)

版权声明:假装有个原创声明……虽然少许博文不属于完全原创,但也是自己辛辛苦苦总结的,转载请注明出处,感谢! https://blog.csdn.net/m0_37454852/article/details/86519120

1095 Cars on Campus (30 分)
Zhejiang University has 8 campuses and a lot of gates. From each gate we can collect the in/out times and the plate numbers of the cars crossing the gate. Now with all the information available, you are supposed to tell, at any specific time point, the number of cars parking on campus, and at the end of the day find the cars that have parked for the longest time period.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N (≤10​4), the number of records, and K (≤8×10​4​​ ) the number of queries. Then N lines follow, each gives a record in the format:

plate_number hh:mm:ss status
where plate_number is a string of 7 English capital letters or 1-digit numbers; hh:mm:ss represents the time point in a day by hour:minute:second, with the earliest time being 00:00:00 and the latest 23:59:59; and status is either in or out.

Note that all times will be within a single day. Each in record is paired with the chronologically next record for the same car provided it is an out record. Any in records that are not paired with an out record are ignored, as are out records not paired with an in record. It is guaranteed that at least one car is well paired in the input, and no car is both in and out at the same moment. Times are recorded using a 24-hour clock.

Then K lines of queries follow, each gives a time point in the format hh:mm:ss. Note: the queries are given in ascending order of the times.

Output Specification:

For each query, output in a line the total number of cars parking on campus. The last line of output is supposed to give the plate number of the car that has parked for the longest time period, and the corresponding time length. If such a car is not unique, then output all of their plate numbers in a line in alphabetical order, separated by a space.

Sample Input:

16 7
JH007BD 18:00:01 in
ZD00001 11:30:08 out
DB8888A 13:00:00 out
ZA3Q625 23:59:50 out
ZA133CH 10:23:00 in
ZD00001 04:09:59 in
JH007BD 05:09:59 in
ZA3Q625 11:42:01 out
JH007BD 05:10:33 in
ZA3Q625 06:30:50 in
JH007BD 12:23:42 out
ZA3Q625 23:55:00 in
JH007BD 12:24:23 out
ZA133CH 17:11:22 out
JH007BD 18:07:01 out
DB8888A 06:30:50 in
05:10:00
06:30:50
11:00:00
12:23:42
14:00:00
18:00:00
23:59:00
Sample Output:

1
4
5
2
1
0
1
JH007BD ZD00001 07:20:09


//感觉这个题有点恶心……难倒是不难,但就是太麻烦了……
//我的思路是,先按照车牌号排序,把那些不匹配的数据剔除掉(即有进无出,或者有出无进的数据);并统计每辆车停留时间
//之后再按时间排序,输入时间点,计算其之前有多少个in和out来计算校园里有多少辆车
//最后按照停留时间排序,把停留时间最长的那些车按字母表顺序输出……

using namespace std;
#include<algorithm>
#include<iostream>
#include<cstdio>
#include<cstring>

typedef struct records//那些输入的数据
{
    char p_num[10];
    int hh, mm, ss;
    char status[5];
}records;
typedef struct stay//每辆车停留的时间记录
{
    char p_num[10];
    int time;
}stay;
stay car[10010] = {0};
int longest = 0;//停留最长时间
records R[10010] = {0};

bool cmp1(records A, records B)
{
    if(strcmp(A.p_num, B.p_num)) return strcmp(A.p_num, B.p_num) < 0;//先按照车牌号排序
    if(A.hh != B.hh) return A.hh < B.hh;//之后按时间排序,不符合先进后出顺序的数据将被剔除
    if(A.mm != B.mm) return A.mm < B.mm;
    return A.ss < B.ss;
}
bool cmp2(records A, records B)//之后按时间排序
{
    if(A.hh != B.hh) return A.hh < B.hh;
    if(A.mm != B.mm) return A.mm < B.mm;
    return A.ss < B.ss;
}
bool cmp3(stay A, stay B)//最后按照停留时间排序,并考虑字母表顺序
{
    if(A.time != B.time) return A.time > B.time;
    return strcmp(A.p_num, B.p_num) < 0;
}

int main()
{
    int N, K, M, i = 0, j = 0, hh, mm, ss, cnt = 0;
    scanf("%d %d", &N, &K);
    for(int i=0; i<N; i++)
    {
        scanf("%s %d:%d:%d %s", R[i].p_num, &R[i].hh, &R[i].mm, &R[i].ss, R[i].status);
    }
    sort(R, R+N, cmp1);//第一次排序
    for(i=0, j=0; i<N-1; )
    {
        if(!strcmp(R[i].p_num, R[i+1].p_num)
        && !strcmp(R[i].status, "in") && !strcmp(R[i+1].status, "out"))//剔除不合要求数据
        {
            R[j] = R[i];
            R[j+1] = R[i+1];
            i+=2, j+=2;
        }
        else i++;
    }
    N = j;
    for(i=0, j=0; i<N; i+=2)//计算每辆车的停留时间
    {
        if(strcmp(R[i].p_num, car[j].p_num))
        {
            if(car[j].time > longest) longest = car[j].time;
            j++;
            strcpy(car[j].p_num, R[i].p_num);
        }
        car[j].time += (R[i+1].hh - R[i].hh)*60*60 + (R[i+1].mm - R[i].mm)*60 + (R[i+1].ss - R[i].ss);
    }
    if(car[j].time > longest) longest = car[j].time;
    M = j+1;
    sort(R, R+N, cmp2);//第二次排序
    for(i=0, j=0; i<K && j<N; i++)
    {
        scanf("%d:%d:%d", &hh, &mm, &ss);
        while(j<N &&
              (R[j].hh < hh
               || R[j].hh == hh && R[j].mm < mm
               || R[j].hh == hh && R[j].mm == mm && R[j].ss <= ss))
        {
            if(!strcmp(R[j].status, "in")) cnt++;//用cnt来记录当时校园里还有多少量车
            else if(!strcmp(R[j].status, "out")) cnt--;
            j++;
        }
        printf("%d\n", cnt);
    }
    sort(car, car+M, cmp3);//第三次排序,将停留时间最长的车牌及其停留时间输出
    for(i=0; i<=M; i++)
    {
        if(car[i].time == longest)
        {
            printf("%s ", car[i].p_num);
        }
        else break;
    }
    printf("%02d:%02d:%02d", longest/3600, (longest%3600)/60, longest%60);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/m0_37454852/article/details/86519120