A1025 PAT Ranking (25 分)

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (≤100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (≤300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:

2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

Sample Output:

9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

题意:

有n(N<=100)个考场,每个考场有若干数量(K <= 300)的学生。给出每个考场中考生的准考证号以及分数,要求将所有考生按分数从高到低排序,并按顺序输出所有考生的准考证号、排名、考场号以及考场内排名。分数相同的排名相同,并按照准考证号顺序输出。

注意:

  1. 定义结构体stu, 将准考证号、分数、考场号以及考场内排名均存入。

  2. 对于同一考场的考生单独排序时,定义num, 用于存放的考生数组下标,每读入一个学生就让num自增。每当读完一个考场,对考场学生进行排序,下标区间为[num - k, num).

  3. 总排名不用存入结构体,直接排序输出即可。

#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

struct Student{
  char id[15];
  int score;
  int location_number;    //考场号
  int local_rank;         //考场内排名
}stu[30010];

bool cmp(Student a, Student b){
  if(a.score != b.score)
    return a.score > b.score;
  else
    return strcmp(a.id, b.id) < 0;  //分数相同按准考证号从小到大排序
}

int main(){
  int n, k, num = 0;
  scanf("%d", &n);
  for(int i = 1; i <= n; i++){
    scanf("%d", &k);
    for(int j = 0; j < k; j++){
      scanf("%s %d", stu[num].id, &stu[num].score);
      stu[num].location_number = i;
      num++;
    }
    sort(stu + num - k, stu + num, cmp);    //stu 为stu[]数组的始地址
    stu[num - k].local_rank = 1;
    for(int j = num - k + 1; j < num; j++){
      if(stu[j].score == stu[j - 1].score){
        stu[j].local_rank = stu[j - 1].local_rank;
      }
      else{
        stu[j].local_rank = j + 1 - (num - k);
      }
    }
  }
  printf("%d\n", num);
  sort(stu, stu + num, cmp);
  int r = 1;
  for(int i = 0; i < num; i++){
    if(i > 0 && stu[i].score != stu[i - 1].score)
      r = i + 1;
    printf("%s %d %d %d\n", stu[i].id, r, stu[i].location_number, stu[i].local_rank);
    
  }
  return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_35093872/article/details/86513601