1120. Friend Numbers (20)

版权声明:文章都是原创,转载请注明~~~~ https://blog.csdn.net/SourDumplings/article/details/86589120

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Two integers are called "friend numbers" if they share the same sum of their digits, and the sum is their "friend ID". For example, 123 and 51 are friend numbers since 1+2+3 = 5+1 = 6, and 6 is their friend ID. Given some numbers, you are supposed to count the number of different friend ID's among them. Note: a number is considered a friend of itself.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N. Then N positive integers are given in the next line, separated by spaces. All the numbers are less than 104.

Output Specification:

For each case, print in the first line the number of different frind ID's among the given integers. Then in the second line, output the friend ID's in increasing order. The numbers must be separated by exactly one space and there must be no extra space at the end of the line.

Sample Input:

8
123 899 51 998 27 33 36 12

Sample Output:

4
3 6 9 26

Python:

#!/usr/bin/env python
# -*- coding: utf-8 -*-
# @Date    : 2018-03-01 15:57:26
# @Author  : 酸饺子 ([email protected])
# @Link    : https://github.com/SourDumplings
# @Version : $Id$

'''
https://www.patest.cn/contests/pat-a-practise/1120
'''


def calc_id(num):
    num_s = str(num)
    res = 0
    for each_d in num_s:
        res += int(each_d)
    return res


def main():
    input()
    num = input().split(' ')
    s = set()
    for each in num:
        id = calc_id(each)
        s.add(id)
    print(len(s))
    l = list(s)
    l.sort()
    output = 0
    for each_id in l:
        if output != 0:
            print(' ', end='')
        else:
            output += 1
        print(each_id, end='')
    print()
    return


if __name__ == '__main__':
    main()
    # code

猜你喜欢

转载自blog.csdn.net/SourDumplings/article/details/86589120