PAT (Advanced Level) Practice A1029 Median (25 分)(C++)(甲级)(归并、中位数)

版权声明:假装有个原创声明……虽然少许博文不属于完全原创,但也是自己辛辛苦苦总结的,转载请注明出处,感谢! https://blog.csdn.net/m0_37454852/article/details/86564980

1029 Median (25 分)
Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1 = { 11, 12, 13, 14 } is 12, and the median of S2 = { 9, 10, 15, 16, 17 } is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

Given two increasing sequences of integers, you are asked to find their median.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (≤2×10
​5
​​ ) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.

Output Specification:

For each test case you should output the median of the two given sequences in a line.

Sample Input:

4 11 12 13 14
5 9 10 15 16 17
Sample Output:

13

using namespace std;
#include<algorithm>
#include<iostream>
#include<cstdio>
#include<cstring>
#include <ctime>
#include <cmath>

int A[200010] = {0};//只能申请一个数组,否则内存不够用
const int INF = (1<<31)-1;//无穷大

int main()
{
    int N, M, i, j, cnt = 0, mid, x;
    scanf("%d", &N);
    for(i=0; i<N; i++) scanf("%d", &A[i]);//把第一个存入数组,第二个边输入边查询
    A[N] = INF;//结尾处设置为无穷大
    scanf("%d", &M);
    mid = (N+M-1)/2;//查询位置
    scanf("%d", &x);//先给x输入一个数,避免
    for(i=0, j=0; cnt < mid; cnt++)
    {
        if(j >= M) x = INF;
        if(x < A[i]) scanf("%d", &x), j++;
        else i++;
    }
    printf("%d", min(A[i], x));
	return 0;
}

猜你喜欢

转载自blog.csdn.net/m0_37454852/article/details/86564980
今日推荐