Count the string HDU - 3336 (KMP)

版权声明:转载请标明出处 https://blog.csdn.net/weixin_41190227/article/details/86589045

t is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example: 
s: "abab" 
The prefixes are: "a", "ab", "aba", "abab" 
For each prefix, we can count the times it matches in s. So we can see that prefix "a" matches twice, "ab" matches twice too, "aba" matches once, and "abab" matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For "abab", it is 2 + 2 + 1 + 1 = 6. 
The answer may be very large, so output the answer mod 10007. 

Input

The first line is a single integer T, indicating the number of test cases. 
For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters. 

Output

For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.

Sample Input

1
4
abab

Sample Output

6

题意:求字符串的每一个子串在原字符串中出现的次数和。

思路:因为next数组表示的是子串中最长公共前后缀串的长度,如果用dp[i]表示该字符串前i个字符中出现任意以第i个字符结尾的前缀的次数,它的递推式是 dp[i]=dp[next[i]]+1,即以第i个字符结尾的前缀数等于以第next[i]个字符为结尾的前缀数加上它自己本身。

/*
@Author: Top_Spirit
@Language: C++
*/
#include <bits/stdc++.h>
using namespace std ;
typedef unsigned long long ull ;
typedef long long ll ;
const int Maxn = 2e5 + 10 ;
const int INF = 0x3f3f3f3f ;
const ull seed = 133 ;
const int MOD = 10007 ;
const double PI = acos(-1.0) ;

string s ;
int n ;
int Next[Maxn], dp[Maxn] ;

void getNext(){
    Next[0] = -1 ;
    int j = 0, k = -1 ;
    while (j < n){
        if(k == -1 || s[j] == s[k]) Next[++j] = ++k ;
        else k = Next[k] ;
    }
}

int main (){
    int T ;
    cin >> T ;
    while (T--){
        cin >> n >> s ;
        getNext() ;
        fill(dp, dp + n, 1) ;
        dp[0] = 0 ;
        ll sum = 0 ;
        for (int i = 1; i <= n; i++){
            dp[i] = dp[Next[i]] + 1 ;
//            cout << i << " " << dp[i] << endl ;
            sum = (sum + dp[i]) % MOD ;
        }
        cout << sum << endl ;
    }
    return 0 ;
}

猜你喜欢

转载自blog.csdn.net/weixin_41190227/article/details/86589045
今日推荐