Be Unique (20)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/AliceGoToAnother/article/details/79358965

题目描述

Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1, 104]. The first one who bets on a unique number wins. For example, if there are 7 people betting on 5 31 5 88 67 88 17, then the second one who bets on 31 wins.

输入

Each input file contains one test case. Each case contains a line which begins with a positive integer N (<=105) and then followed by N bets. The numbers are separated by a space.

输出

For each test case, print the winning number in a line. If there is no winner, print “None” instead.

样例输入

7 5 31 5 88 67 88 17
5 888 666 666 888 888

样例输出

31
None

#include <cstdio>
int main()
{
    int n;
    int hash[10];
    while(1)
    {
        //初始化哈希数组
        for(int i = 0;i < 10;i++)
            hash[i] = 0;
        scanf("%d",&n);
        if(n == 0) return 0;
        int a[n];

        //输入n个数
        for(int i = 0;i < n;i++)
        {
            scanf("%d",&a[i]);
        }

        //录入第一个数的哈希匹配
        while(a[0])
        {
            int temp = a[0] % 10;
            if(hash[temp] == 0)
                hash[temp] = 1;
            else break;
            a[0] /= 10;
        }

        //从第二个数开始遍历
        int i;
        for(i = 1;i < n;i++)
        {
            int num = a[i];
            while(a[i])
            {
                int temp = a[i]%10;
                if(hash[temp] == 0)
                    hash[temp] = 1;
                else break;
                a[i] /= 10;
            }
            if(a[i] == 0)
            {
                printf("%d\n",num);
                break;
            }
        }
        if(i == n) printf("None\n");

    }

}

猜你喜欢

转载自blog.csdn.net/AliceGoToAnother/article/details/79358965