HDU 1272-小希的迷宫【简单并查集】

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/include_peng/article/details/86580107

题目描述

上次Gardon的迷宫城堡小希玩了很久(见Problem B),现在她也想设计一个迷宫让Gardon来走。但是她设计迷宫的思路不一样,首先她认为所有的通道都应该是双向连通的,就是说如果有一个通道连通了房间A和B,那么既可以通过它从房间A走到房间B,也可以通过它从房间B走到房间A,为了提高难度,小希希望任意两个房间有且仅有一条路径可以相通(除非走了回头路)。小希现在把她的设计图给你,让你帮忙判断她的设计图是否符合她的设计思路。比如下面的例子,前两个是符合条件的,但是最后一个却有两种方法从5到达8。 

Input

输入包含多组数据,每组数据是一个以0 0结尾的整数对列表,表示了一条通道连接的两个房间的编号。房间的编号至少为1,且不超过100000。每两组数据之间有一个空行。 
整个文件以两个-1结尾。 

Output

对于输入的每一组数据,输出仅包括一行。如果该迷宫符合小希的思路,那么输出"Yes",否则输出"No"。 

Sample Input

6 8  5 3  5 2  6 4
5 6  0 0

8 1  7 3  6 2  8 9  7 5
7 4  7 8  7 6  0 0

3 8  6 8  6 4
5 3  5 6  5 2  0 0

-1 -1

Sample Output

Yes
Yes
No

题意

给出一个无向图,判断每两个点之间是否有且仅有一条路径相通。

POJ1308与本题题意相同。

思路

这道题的难度不算很大,给出一条边的两个端点,查找两个端点的父亲是否相同,若相同则说明这两个点已存在连通的路径,答案为No,若不相同,则建立联系。最后判断所有的点是否在一个集合里,若是,为Yes,反之,为No

代码

#include<iostream>
#include<cstdio>
#include<map>
using namespace std;

const int Max = 100005;
int par[Max];
map<int,bool> mp;
map<int,bool>::iterator it;
void Init()
{
    for(int i = 0; i < Max; i++)
        par[i] = i;
}
int Find(int x)
{
    if(x==par[x])
        return par[x];
    else
        return par[x] = Find(par[x]);
}
bool Union(int x, int y)
{
    x = Find(x);
    y = Find(y);
    if(x!=y)
    {
        par[y] = x;
        return true;
    }
    else
        return false;
}
int main()
{
    int a,b;
    bool flag = true;
    Init();
    while(scanf("%d %d", &a, &b)!=EOF)
    {
        if(a==0&&b==0)
        {
            if(flag)//判断所有的点是否在一个集合里,若是,为Yes,反之,为No。
            {
                a = mp.begin()->first;
                for(it = mp.begin(); it!=mp.end(); it++)
                {
                    if(Union(a,it->first))
                    {
                        flag = false;
                        break;
                    }
                }
            }
            if(flag)
                printf("Yes\n");
            else
                printf("No\n");
            flag = true;
            Init();
            mp.clear();
        }
        else if(a==-1&&b==-1)
            break;
        else
        {
            bool temp = Union(a,b);
            if(mp.find(a)==mp.end())
                mp[a] = true;
            if(mp.find(b)==mp.end())
                mp[b] = true;
            if(!temp)
                flag = false;
        }
    }
    return 0;
}

如有错误请指明~   ฅ●ω●ฅ

猜你喜欢

转载自blog.csdn.net/include_peng/article/details/86580107