GZHU18级寒假训练:Leo's Trial-D

HDU-2845(DP)

  • Bean-eating is an interesting game, everyone owns an MN matrix, which is filled with different qualities beans. Meantime, there is only one bean in any 11 grid. Now you want to eat the beans and collect the qualities, but everyone must obey by the following rules: if you eat the bean at the coordinate(x, y), you can’t eat the beans anyway at the coordinates listed (if exiting): (x, y-1), (x, y+1), and the both rows whose abscissas are x-1 and x+1.

Now, how much qualities can you eat and then get ?

  • Input
    There are a few cases. In each case, there are two integer M (row number) and N (column number). The next M lines each contain N integers, representing the qualities of the beans. We can make sure that the quality of bean isn’t beyond 1000, and 1<=M*N<=200000.
  • Output
    For each case, you just output the MAX qualities you can eat and then get.
  • Sample Input
    4 6
    11 0 7 5 13 9
    78 4 81 6 22 4
    1 40 9 34 16 10
    11 22 0 33 39 6
  • Sample Output
    242

  • 首先将每一行所能吃到的最大豆的数量求出来,即求出每一行非连续的最大子序列和,然后将每一行所求的最大豆数量保存到数组序列中,同样的方法求出数组序列的非连续的最大子序列和即为所能吃到的最大豆的数量。

  • 状态转移方程:sum[i] = dp[i-2]+a[i],dp[i] = max(sum[i],dp[i-1]),2<=i<=n

  • 初始化sum[0]=dp[0]=0,sum[1]=dp[1]=a[1]。


#include <iostream>
#include <cstdio>
using namespace std;
#define N 200003
int sum[N],dp[N],map[N],row[N];

int solve(int a[],int n)
{
    int i;
    sum[0] = 0;
    dp[0] = 0;
    sum[1] = a[1];
    dp[1] = a[1];//数组dp代表最大豆的数量
    for(i=2; i<=n; i++)
    {
        sum[i] = dp[i-2]+a[i];
        dp[i] = max(sum[i],dp[i-1]);
    }
    return dp[n];
}

int main()
{
    int i,j,n,m,sum;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        for(i=1; i<=n; i++)
        {
            for(j=1; j<=m; j++)
                scanf("%d",&map[j]);
            row[i] = solve(map,m);
        }
        sum = solve(row,n);
        printf("%d\n",sum);
    }
    return 0;
}

源:https://www.cnblogs.com/yazhou/p/3739746.html

猜你喜欢

转载自blog.csdn.net/weixin_43316754/article/details/86688066