POJ1604 UVA568 UVALive5499 Just the Facts【模除+打表】

Just the Facts
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9631 Accepted: 5042

Description

The expression N!, read as "N factorial," denotes the product of the first N positive integers, where N is nonnegative. So, for example,
N N!

0 1

1 1

2 2

3 6

4 24

5 120

10 3628800

For this problem, you are to write a program that can compute the last non-zero digit of any factorial for (0 <= N <= 10000). For example, if your program is asked to compute the last nonzero digit of 5!, your program should produce "2" because 5! = 120, and 2 is the last nonzero digit of 120.

Input

Input to the program is a series of nonnegative integers not exceeding 10000, each on its own line with no other letters, digits or spaces. For each integer N, you should read the value and compute the last nonzero digit of N!.

Output

For each integer input, the program should print exactly one line of output. Each line of output should contain the value N, right-justified in columns 1 through 5 with leading blanks, not leading zeroes. Columns 6 - 9 must contain " -> " (space hyphen greater space). Column 10 must contain the single last non-zero digit of N!.

Sample Input
1
2
26
125
3125
9999

Sample Output
1 -> 1
2 -> 2
26 -> 4
125 -> 8
3125 -> 2
9999 -> 8

Source

South Central USA 1997

Regionals 1997 >> North America - South Central USA

问题链接POJ1604 UVA568 UVALive5499 Just the Facts
问题简述
    计算阶乘n!的最后一个不为0的数字。
问题分析
    迭代计算,每次去掉结果中最后的0,然后取出1位就是最低位。由于最后一个不为0的数字与高位(模除100000即可)无关。大表是必要的,可以避免重复计算。
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C++语言程序如下:

/* POJ1604 UVA568 UVALive5499 Just the Facts */

#include <iostream>
#include <cstdio>

using namespace std;

const int MOD = 100000;
const int N = 10000;
int ans[N + 1];

void init()
{
    ans[0] = 1;
    ans[1] = 1;
    int t = 1;
    for(int i = 2; i <= N; i++) {
        t *= i;
        while(t % 10 == 0) t /= 10;
        ans[i] = t % 10;
        t %= MOD;
    }
}

int main()
{
    init();

    int n;
    while(~scanf("%d", &n))
        printf("%5d -> %d\n", n, ans[n]);

    return 0;
}

猜你喜欢

转载自www.cnblogs.com/tigerisland45/p/10425588.html