HDU - 1024 Max Sum Plus Plus

Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S 1, S 2, S 3, S 4 ... S x, ... S n (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ S x ≤ 32767). We define a function sum(i, j) = S i + ... + S j (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i 1, j 1) + sum(i 2, j 2) + sum(i 3, j 3) + ... + sum(i m, j m) maximal (i x ≤ i y ≤ j x or i x ≤ j y ≤ j x is not allowed).

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(i x, j x)(1 ≤ x ≤ m) instead. ^_^

Input

Each test case will begin with two integers m and n, followed by n integers S 1, S 2, S 3 ... S n.
Process to the end of file.

Output

Output the maximal summation described above in one line.

Sample Input

1 3 1 2 3
2 6 -1 4 -2 3 -2 3

Sample Output

6
8

思路:

看了一篇博客,才对此题一知半解,附上博客链接。

传送门

代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;
typedef long long ll;
const int maxn=1e6+5;
ll a[maxn];
ll pre[maxn];
int n,m;
int main()
{
    while (scanf("%d%d",&m,&n)!=EOF)
    {
        for (int i=1;i<=n;i++)
            scanf("%lld",&a[i]);
        memset (pre,0,sizeof(pre));
        for (int i=1;i<=m;i++)
        {
            ll temp=0;
            for (int j=1;j<=i;j++) temp+=a[j];
            pre[n]=temp;
            for (int j=i+1;j<=n;j++)
            {
                temp=max(pre[j-1],temp)+a[j];
                pre[j-1]=pre[n];
                pre[n]=max(temp,pre[n]);
            }
        }
        printf("%lld\n",pre[n]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41410799/article/details/87784952