杭电max sum问题

Problem Description

Given a sequence a[1],a[2],a[3]…a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

Output

For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases

Sample Input

2

5 6 -1 5 4 -7

7 0 6 -1 1 -6 7 -5

Sample Output

Case 1:

14 1 4

Case 2:

7 1 6

本题为动态规划问题,求最大连续子区间和,并且输出和,起始位置,结束位置

思路:输入一组数据,用summax来跟踪最大和,sum做连加运算的跟踪,k来跟踪最大区间的起始位置
当sum<0时,置sum=0(因为当前的连加和为负的话,若后面继续为负责越加越小,若后面为正,那么从后面作为sum的起始更合适),并且让k移动到后一位,即k=i+2(因为k从1初始,i从0初始,k向后移动一位相当于i+2,)

#include <iostream>
#include <cstdio>
using namespace std;
int main(){
    int t,n,c,i;
    int a[100002];
    scanf("%d\n",&t);
    for(c=0;c<t;c++){
        int summax=-1000,sum=0,st=0,en=0,k=1;
        scanf("%d",&n);
        for(i=0;i<n;i++){
            scanf("%d",&a[i]);
        }
        for(i=0;i<n;i++){
            sum+=a[i];
            if(summax<sum){
                summax=sum;
                st=k;
                en=i+1;
            }
            if(sum<0){
                sum=0;
                k=i+2;
            }
        }
        printf("case %d:\n%d %d %d\n",c,summax,st,en);
        if(c!=t)cout<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/hanleiliu/article/details/88100377