PAT_甲级_1025

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/lzc842650834/article/details/87915085

1025 PAT Ranking (25 分)

(算是一道经典的排序题)

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive number N (≤100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (≤300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:
For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank
The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:

2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

Sample Output:

9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

注意点:字符串比较大小用strcmp,习惯性的用了 “>”

#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<map>
#include<string.h>
using namespace std;
typedef struct info{
    char id[20];
    int score;
    int location; //地区
    int rank_1; //地区排名
    int rank_2; //总体排名
}info;
info stu[300010];
int loc[110]; //每个地区的学生数量
int sum = 0; //记录数据在stu的位置
bool cmp_1(info a, info b)
{
    return a.score > b.score;
}
bool cmp_2(info a, info b)
{
    if (a.score == b.score) {
        return strcmp(a.id, b.id) < 0;
    } else {
        return a.score > b.score;
    }
}
int main()
{
    int T;
    cin >> T;
    for (int tt = 0; tt < T; tt++) {
        cin >> loc[tt];
        for (int i = 0 + sum; i < sum + loc[tt]; i++) {
            char id_temp[20];
            int score_temp;
            cin >> stu[i].id >> score_temp;
            stu[i].score = score_temp;
            stu[i].location = tt + 1;
        }
        sort(stu + sum, stu + sum + loc[tt], cmp_1);
        stu[sum].rank_1 = 1;
        for (int i = 1; i < loc[tt]; i++) {
            if (stu[i + sum].score == stu[i - 1 + sum].score) {
                stu[i + sum].rank_1 = stu[i - 1 + sum].rank_1;
            } else {
                stu[i + sum].rank_1 = i + 1;
            }
        }
        sum += loc[tt];
    }
    sort(stu, stu + sum, cmp_2);
    stu[0].rank_2 = 1;
    for (int i = 1; i < sum; i++) {
        if (stu[i].score == stu[i - 1].score) {
            stu[i].rank_2 = stu[i - 1].rank_2;
        } else {
            stu[i].rank_2 = i + 1;
        }
    }
    cout << sum << endl;
    for (int i = 0; i < sum; i++) {
        printf("%s %d %d %d\n", stu[i].id, stu[i].rank_2, stu[i].location, stu[i].rank_1);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/lzc842650834/article/details/87915085