杭电 2000 ASCII码排序 c++

Problem Description
输入三个字符后,按各字符的ASCII码从小到大的顺序输出这三个字符。
Input
输入数据有多组,每组占一行,有三个字符组成,之间无空格。
Output
对于每组输入数据,输出一行,字符中间用一个空格分开。
Sample Input
qwe
asd
zxc
Sample Output
e q w
a d s
c x z

#include<iostream>
#include<iomanip>
using namespace std;
#define PI 3.1415927
int main() {
	char a, b, c, x, y, z;
	while (cin >> a >> b >> c) {
		x = a < b ? a : b;
		x = x < c ? x : c;
		z = a > b ? a : b;
		z = z > c ? z : c;
		y = a + b + c - x - z;
		cout << x << " " << y << " " << z << endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_41274723/article/details/88285766