max sum(子列之和最大)

max sum(子列之和最大)
#HDOJ
原题
参考代码

Problem Description
Given a sequence a[1],a[2],a[3]…a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

Sample Output
Case 1:
14 1 4

Case 2:
7 1 6

#include<stdio.h>
int main()
{
   int end,begin,temp,max;    

   int e,f,k=0,flag=1;  
   int a[100005],n,m,i; //数组接收数据,次数,个数,下标变量 
   				   		//初始化
   scanf("%d",&n);   	//输入次数
   while(n--)
   { 
   	begin=end=0;
   	k++;    			//case次数
   	
   	scanf("%d",&m);     //输入数据
    for(i=1;i<=m;i++)
		scanf("%d",&a[i]);

	temp=0;             // 和初始化
	max=-999999; 		//存放最小值
	begin=e=1;          //标记输入数据后,begin,e变化
	f=1;                //初始化

	for(i=1;i<=m;i++)
	{
		temp +=a[i];
		if(temp>max)    //大于最小值,把变量赋值给全新的变量,最后输出时不会出问题
		{
			e=begin;    
			f=i;
			max=temp;
		}

		if(temp<0)		//本人有考虑到
		{
 			begin = i+1; //当和小于0时,跳过,归零重新计算
 			temp = 0; 
		}
	}

	printf("Case %d:\n",k);	
	printf("%d %d %d\n",max,e,f);
	if(n!=0) printf("\n"); //不是最后一个 就输出换行符
   }

}

这个是参考另一个博主 不是自己写的!!!!

猜你喜欢

转载自blog.csdn.net/yumy_buie/article/details/88123597
今日推荐