POJ - 3264——Balanced Lineup(入门线段树)

Balanced Lineup
Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 68466   Accepted: 31752
Case Time Limit: 2000MS

Description

For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers, N and Q
Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i 
Lines N+2..N+Q+1: Two integers A and B (1 ≤ A ≤ B ≤ N), representing the range of cows from A to B inclusive.

Output

Lines 1..Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0

题目链接:

http://poj.org/problem?id=3264

题目大意:

给定一个区间N,并初始化该区间,Q次询问区间内的最大值减最小值。

题目分析:

这是一道基础入门级的线段树题目。线段树是二分的思想。开结构体存储节点的左、右区间和最大、最小值。根节点的左区间是1,右区间是N。

父节点分成左孩子和右孩子,即左孩子的区间为父节点的左区间到父节点的中值((l+r)/2),右孩子的区间为父节点的中值加一((l+r)/2+1)到父节点的右区间。

AC代码如下:

#include<stdio.h>
#include<algorithm>
using namespace std;
const int MAX=1E6+10;

struct s{
    int left,right;
    int maxx,minn;
}tree[MAX<<2];

void btree(int k,int l,int r)    //建树 
{
    tree[k].left=l;    //节点左右区间更新 
    tree[k].right=r;
    if(l==r)    //叶子 
    {
        scanf("%d",&tree[k].minn);
        tree[k].maxx=tree[k].minn;
        return ;
    }
    int mid=(l+r)/2;
    btree(k<<1,l,mid);   //左孩子 
    btree(k<<1|1,mid+1,r);   //右孩子 
    tree[k].maxx=max(tree[k<<1].maxx,tree[k<<1|1].maxx);   //更新节点最大值 
    tree[k].minn=min(tree[k<<1].minn,tree[k<<1|1].minn);   //更新节点最小值 
}

int ma,mi;
void query(int k,int l,int r)    //询问 
{
    if(tree[k].left>=l&&tree[k].right<=r)
    {
        ma=max(tree[k].maxx,ma);
        mi=min(tree[k].minn,mi);
        return ;
    }
    int mid=(tree[k].left+tree[k].right)/2;
    if(mid>=r)    //节点中值大于询问区间右边  询问左孩子 
    {
        query(k<<1,l,r);
    }
    else if(mid<l)    //节点中值小于询问左边   询问右孩子 
    {
        query(k<<1|1,l,r);
    }
    else     //左、右都需要询问 
    {
        query(k<<1,l,r);
        query(k<<1|1,l,r);
    }
    return ;
}

int main()
{
    int n,q;
    scanf("%d%d",&n,&q);
    btree(1,1,n);
    for(int i=1;i<=q;i++)
    {
        ma=-1;mi=0x3f3f3f3f;
        int a,b;
        scanf("%d%d",&a,&b);
        query(1,a,b);
        printf("%d\n",ma-mi);
    }
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/noback-go/p/10541706.html
今日推荐