H 3038 - How Many Answers Are Wrong

How Many Answers Are Wrong

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 17886 Accepted Submission(s): 6223

Problem Description
TT and FF are … friends. Uh… very very good friends -________-b

FF is a bad boy, he is always wooing TT to play the following game with him. This is a very humdrum game. To begin with, TT should write down a sequence of integers-_-!!(bored).

Then, FF can choose a continuous subsequence from it(for example the subsequence from the third to the fifth integer inclusively). After that, FF will ask TT what the sum of the subsequence he chose is. The next, TT will answer FF’s question. Then, FF can redo this process. In the end, FF must work out the entire sequence of integers.

BoringBoringa very very boring game!!! TT doesn’t want to play with FF at all. To punish FF, she often tells FF the wrong answers on purpose.

The bad boy is not a fool man. FF detects some answers are incompatible. Of course, these contradictions make it difficult to calculate the sequence.

However, TT is a nice and lovely girl. She doesn’t have the heart to be hard on FF. To save time, she guarantees that the answers are all right if there is no logical mistakes indeed.

What’s more, if FF finds an answer to be wrong, he will ignore it when judging next answers.

But there will be so many questions that poor FF can’t make sure whether the current answer is right or wrong in a moment. So he decides to write a program to help him with this matter. The program will receive a series of questions from FF together with the answers FF has received from TT. The aim of this program is to find how many answers are wrong. Only by ignoring the wrong answers can FF work out the entire sequence of integers. Poor FF has no time to do this job. And now he is asking for your help~(Why asking trouble for himself~~Bad boy)

Input
Line 1: Two integers, N and M (1 <= N <= 200000, 1 <= M <= 40000). Means TT wrote N integers and FF asked her M questions.

Line 2…M+1: Line i+1 contains three integer: Ai, Bi and Si. Means TT answered FF that the sum from Ai to Bi is Si. It’s guaranteed that 0 < Ai <= Bi <= N.

You can assume that any sum of subsequence is fit in 32-bit integer.

Output
A single line with a integer denotes how many answers are wrong.

Sample Input
10 5
1 10 100
7 10 28
1 3 32
4 6 41
6 6 1

Sample Output
1

TT写n个整数,FF问m次。每次问的是[ a i ai , b i bi ]( a i ai , b i bi 表示数的下标,即第几个)之间的和是多少,TT会给出答案,答案有可能是错误的。FF会忽略错误的答案。问TT给出的答案有多少个是错误的。

带权并查集。

两个数组,f 数组用来做并查集。value 数组用来存 x 到 f[x] 即 它的根节点之间数的总和。

输入 a i ai , b i bi , s i si 。如果 a i ai b i bi 在同一个并查集,则判断[ a i ai , b i bi ]的总和和si是否相等。不相等计数器num++;
如果不在同一个并查集,则把 a i ai 的根节点fa并在fb的下面。同时更新 value[fa] 的值。

怎么更新两个根节点之间的关系的具体内容在下面这个网址。运用向量来解释,简洁明了,受益匪浅。
https://www.cnblogs.com/liyinggang/p/5327055.html

#include<stdio.h>

int f[200001] = {},value[200001] = {},ai,bi,si;

int find(int x)
{
	if (x == f[x]) return x;
	int t = find(f[x]);
	value[x] = value[x] + value[f[x]];
	f[x] = t;
	return t;
}


int main()
{
	int n,m,num;
	while (scanf("%d%d",&n,&m) != EOF)
	{
		num = 0;
		for (int i = 0;i<=n;i++)
		{
			f[i] = i;
			value[i] = 0;
		}
		for (int i = 1;i<=m;i++)	
		{
			scanf("%d%d%d",&ai,&bi,&si);
			ai--; // 我是用(ai-1,bi]来表示[ai,bi]的总和,所以这里要ai--。
			int fa = find(ai),fb = find(bi);
			if (fa == fb) 
			{
				if (value[ai] - value[bi] != si) num++;
			}
			else
			{
				value[fa] = value[bi] + si - value[ai];
				f[fa] = fb;
			}
		}
		printf("%d\n",num);
	}
	return 0;
}   

猜你喜欢

转载自blog.csdn.net/EIP_silly/article/details/87994237