hdu1050-Moving Tables(贪心思想)

原题链接:

http://acm.hdu.edu.cn/showproblem.php?pid=1050

 题目:

Moving Tables

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 44956    Accepted Submission(s): 14641


 

Problem Description

The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure. 



The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving. 



For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.

 

 

Input

The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the same manner as above.

 

 

Output

The output should contain the minimum time in minutes to complete the moving, one per line.

 

 

Sample Input

 



50 60 
70 80 
10 20 
30 40 

1 3 
2 200 

10 100 
80 20
30 50 

 

 

Sample Output

 

10
20
30

 题目大意:

        有一条走廊,走廊两边各有200房间。现在要将桌子从一个房间移动到另外一个房间,但是走廊足够窄,一次只能容得下一张桌子移动。每次移动桌子都会花费10min时间,且在移动路径不交错的情况下。问最少移动时间。

结题思路:

        使用贪心思想。

AC代码:

#include <cstdio>
#include <algorithm>
using namespace std;

const int N = int(2e2 + 5);

typedef struct _Node
{
	int s, t;
} Node;

bool g_compareASC(const Node &a, const Node &b)
{
	return a.s < b.s;
}

Node g_arr[N];
int g_n;

int main()
{
	int T;
	scanf("%d", &T);
	while (T--)
	{
		scanf("%d", &g_n);
		int i;
		for (i = 0; i < g_n; i++) 
		{
			scanf("%d %d", &g_arr[i].s, &g_arr[i].t);
			if (g_arr[i].s > g_arr[i].t)
			{
				g_arr[i].s ^= g_arr[i].t ^= g_arr[i].s ^= g_arr[i].t;
			}
		}

		// 对g_arr升序排序
		sort(g_arr, g_arr + g_n, g_compareASC);

		int cnt = 0;
		int flag = 0;
		while (flag < g_n)
		{
			int temp = 0;
			for (i = 0; i < g_n; i++)
			{
				if (g_arr[i].s > temp)
				{
					temp = g_arr[i].t + g_arr[i].t % 2;
					flag ++;
					g_arr[i].s = 0;
				}
			}
			cnt ++;
		}
		printf("%d\n", cnt * 10);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_41645983/article/details/88676951
今日推荐