POJ 2386(dfs)

Description

Due to recent rains, water has pooled in various places in Farmer John’s field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water (‘W’) or dry land (’.’). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.

Given a diagram of Farmer John’s field, determine how many ponds he has.

Input
  • Line 1: Two space-separated integers: N and M

  • Lines 2…N+1: M characters per line representing one row of Farmer John’s field. Each character is either ‘W’ or ‘.’. The characters do not have spaces between them.

Output
  • Line 1: The number of ponds in Farmer John’s field.
Sample Input

10 12
W…WW.
.WWW…WWW
…WW…WW.
…WW.
…W…
…W…W…
.W.W…WW.
W.W.W…W.
.W.W…W.
…W…W.

Sample Output

3

Hint

OUTPUT DETAILS:

There are three ponds: one in the upper left, one in the lower left,and one along the right side.

代码+题解

#include<cstdio>
#include<string>
#include<cstring>
using namespace std;
int n,m;
char arr[105][105];
void dfs(int i,int j)
{
    if(i<0||i>=n||j<0||j>=m)return;               //如果遇到非法位置,直接return。
    arr[i][j]='.';
    if(arr[i-1][j-1]=='W')             //寻找八个方向是否有水。
        dfs(i-1,j-1);
    if(arr[i-1][j]=='W')
        dfs(i-1,j);
    if(arr[i-1][j+1]=='W')
        dfs(i-1,j+1);
    if(arr[i][j-1]=='W')
        dfs(i,j-1);
    if(arr[i][j+1]=='W')
        dfs(i,j+1);
    if(arr[i+1][j-1]=='W')
        dfs(i+1,j-1);
    if(arr[i+1][j]=='W')
        dfs(i+1,j);
    if(arr[i+1][j+1]=='W')
        dfs(i+1,j+1);
    return;
}
int main()
{
    scanf("%d%d",&n,&m);
    for(int i=0;i<n;i++)
    {
        getchar();            //输入字符串,注意换行。
        for(int j=0;j<m;j++)
        {
            scanf("%c",&arr[i][j]);
        }
    }
    int ans=0;
    for(int i=0;i<n;i++)            //寻找有水的地方
    {
        for(int j=0;j<m;j++)
        {
            if(arr[i][j]=='W')
            {
                dfs(i,j);              //执行dfs函数。
                ans++;
            }
        }
    }
    printf("%d\n",ans);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_43105110/article/details/88087372