PAT(甲级)1051.LCA in a Binary Tree(30)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/ASJBFJSB/article/details/89068719

PAT 1051.LCA in a Binary Tree(30)
The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.
Given any two nodes in a binary tree, you are supposed to find their LCA.

输入格式:
Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 1,000), the number of pairs of nodes to be tested; and N (≤ 10,000), the number of keys in the binary tree, respectively. In each of the following two lines, N distinct integers are given as the inorder and preorder traversal sequences of the binary tree, respectively. It is guaranteed that the binary tree can be uniquely determined by the input sequences. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.

输出格式:
For each given pair of U and V, print in a line LCA of U and V is A. if the LCA is found and A is the key. But if A is one of U and V, print X is an ancestor of Y. where X is A and Y is the other node. If U or V is not found in the binary tree, print in a line ERROR: U is not found. or ERROR: V is not found. or ERROR: U and V are not found..

输入样例:

6 8
7 2 3 4 6 5 1 8
5 3 7 2 6 4 8 1
2 6
8 1
7 9
12 -3
0 8
99 99

输出样例:

LCA of 2 and 6 is 3.
8 is an ancestor of 1.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.

题目分析:
1.求解最近公共祖先。题目中中给出了二叉树的先序遍历和中序遍历,因此可以重构二叉树。
2.将先序或后序序列中的元素保存在map表,标记其是否出现过。方便后边的查询。
3.
(1)u和v均未在map表中出现过,直接输出a and b are not found
(2)u和v只有一个在map表中,直接输出另外一个未找到,a is not found.
(3)使用LCA函数求解公共祖先所对应的节点。下边仔细分析LAC:

在这里插入图片描述
对于LCA算法,如果当前的两个节点在树的两个分支,此时树根节点就是公共祖先。如果两个节点同时在树根的一侧,则其中一个节点是另外一个节点的最近公共祖先。

AC代码:

#include <bits/stdc++.h>
using namespace std;
const int maxn = 10010;

map<int, bool> mp;
int in[maxn], pre[maxn];

struct node{
    int data;
    node* lchild;
    node* rchild;
};

//二叉树重构模板
node* build(int preL, int preR, int inL, int inR){
    if(preL>preR)return NULL;
    node* root = new node;
    root->data = pre[preL];
    int k;
    for(k=inL; k<=inR; ++k){
        if(in[k]==pre[preL])break;
    }
    int leftNum = k-inL;
    root->lchild = build(preL+1, preL+leftNum, inL, k-1);
    root->rchild = build(preL+leftNum+1, preR, k+1, inR);
    return root;
}

node* lca(node* root, int u, int v){
    if(root==NULL)
        return NULL;
    if(root->data==u || root->data==v)
        return root;
    node* left  = lca(root->lchild, u, v);
    node* right = lca(root->rchild, u, v);
    if(left && right)return root;
    return left==NULL?right:left;
}

int main(){
    int m, n, u, v;
    scanf("%d%d", &m, &n);
    for(int i=0; i<n; ++i){
        scanf("%d", &in[i]);
        mp[in[i]] = true;
    }
    for(int i=0; i<n; ++i){scanf("%d", &pre[i]);}
    node* root = build(0, n-1, 0, n-1);
    for(int i=0; i<m; ++i){
        scanf("%d %d", &u, &v);
        if(mp[u]==false && mp[v]==false)
            printf("ERROR: %d and %d are not found.\n", u, v);
        else if(mp[u]==false || mp[v]==false)
            printf("ERROR: %d is not found.\n",mp[u]==false?u:v);
        else{
            node* tmp = lca(root, u, v);
            if(tmp->data==u || tmp->data==v){
            	if(tmp->data==u)
                	printf("%d is an ancestor of %d.\n", u,v);
                else
                	printf("%d is an ancestor of %d.\n", v, u);
            }
            else{
                printf("LCA of %d and %d is %d.\n", u, v, tmp->data);
            }
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/ASJBFJSB/article/details/89068719
今日推荐