POJ - 2104 K-th Number(主席树||划分树)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/chenshibo17/article/details/88561864

You are working for Macrohard company in data structures department. After failing your previous task about key insertion you were asked to write a new data structure that would be able to return quickly k-th order statistics in the array segment. 
That is, given an array a[1...n] of different integer numbers, your program must answer a series of questions Q(i, j, k) in the form: "What would be the k-th number in a[i...j] segment, if this segment was sorted?" 
For example, consider the array a = (1, 5, 2, 6, 3, 7, 4). Let the question be Q(2, 5, 3). The segment a[2...5] is (5, 2, 6, 3). If we sort this segment, we get (2, 3, 5, 6), the third number is 5, and therefore the answer to the question is 5.

Input

The first line of the input file contains n --- the size of the array, and m --- the number of questions to answer (1 <= n <= 100 000, 1 <= m <= 5 000). 
The second line contains n different integer numbers not exceeding 10 9 by their absolute values --- the array for which the answers should be given. 
The following m lines contain question descriptions, each description consists of three numbers: i, j, and k (1 <= i <= j <= n, 1 <= k <= j - i + 1) and represents the question Q(i, j, k).

Output

For each question output the answer to it --- the k-th number in sorted a[i...j] segment.

Sample Input

7 3
1 5 2 6 3 7 4
2 5 3
4 4 1
1 7 3

Sample Output

5
6
3

Hint

This problem has huge input,so please use c-style input(scanf,printf),or you may got time limit exceed.

      区间第K大,当作模板练习把~;

      1.划分树代码

扫描二维码关注公众号,回复: 5884450 查看本文章
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
const int maxn = 200010;
int tree[20][maxn];
int sorted[maxn];
int toleft[20][maxn];
void build(int l, int r, int dep) {
	if (l == r)return;
	int mid = (l + r) >> 1;
	int same = mid - l + 1;
	for (int i = l; i <= r; i++) {
		if (tree[dep][i] < sorted[mid])
			same--;
	}
	int lpos = l;
	int rpos = mid + 1;
	for (int i = l; i <= r; i++) {
		if (tree[dep][i] < sorted[mid])
			tree[dep + 1][lpos++] = tree[dep][i];
		else if (tree[dep][i] == sorted[mid] && same > 0) {
			tree[dep + 1][lpos++] = tree[dep][i];
			same--;
		}
		else
			tree[dep + 1][rpos++] = tree[dep][i];
		toleft[dep][i] = toleft[dep][l-1] + lpos - l;
	}
	build(l, mid, dep + 1);
	build(mid + 1, r, dep + 1);
}
int query(int L, int R, int l, int r, int dep, int k) {
	if (l == r)return tree[dep][l];
	int mid = (L + R) >> 1;
	int cnt = toleft[dep][r] - toleft[dep][l - 1];
	if (cnt >= k) {
		int newl = L + toleft[dep][l-1] - toleft[dep][L-1];
		int newr = newl + cnt - 1;
		return query(L, mid, newl, newr, dep + 1, k);
	}
	else {
		int newr = r + toleft[dep][R] - toleft[dep][r];
		int newl = newr - (r - l - cnt);
		return query(mid + 1, R, newl, newr, dep + 1, k - cnt);
	}
}
int main() {
	int n, m; 
	while (scanf("%d%d", &n, &m) == 2) { 
		memset(tree, 0, sizeof(tree)); 
		for (int i = 1; i <= n; i++){ 
			scanf("%d", &tree[0][i]);
			sorted[i] = tree[0][i];
		}
		sort(sorted + 1, sorted + n + 1);
		build(1, n, 0); 
		int s, t, k; 
		while (m--) { 
			scanf("%d%d%d", &s, &t, &k);
			printf("%d\n", query(1, n, s, t, 0, k));
		} 
	}
	return 0;
}

        2.主席树代码

#include <algorithm>
#include <cstdio>
using namespace std;
const int MAXN = 100010;
const int M = MAXN * 30;
int n, q, m, tot;
int a[MAXN], t[MAXN];
int T[M], lson[M], rson[M], c[M];
void Init_hash(){
	for (int i = 1; i <= n; i++)
		t[i] = a[i];
	sort(t + 1, t + 1 + n);
	m = unique(t + 1, t + 1 + n) - t - 1;
}
int build(int l, int r){
	int root = tot++;
	c[root] = 0;
	if (l != r){
		int mid = (l + r) >> 1;
		lson[root] = build(l, mid);
		rson[root] = build(mid + 1, r);
	}
	return root;
}
int Hash(int x){
	return lower_bound(t + 1, t + 1 + m, x) - t;
}
int update(int root, int pos, int val){
	int newroot = tot++, tmp = newroot;
	c[newroot] = c[root] + val;
	int l = 1, r = m;
	while (l < r){
		int mid = (l + r) >> 1;
		if (pos <= mid){
			lson[newroot] = tot++; rson[newroot] = rson[root];
			newroot = lson[newroot]; root = lson[root];
			r = mid;
		}
		else{
			rson[newroot] = tot++; lson[newroot] = lson[root];
			newroot = rson[newroot]; root = rson[root];
			l = mid + 1;
		}
		c[newroot] = c[root] + val;
	}
	return tmp;
}
int query(int left_root, int right_root, int k){
	int l = 1, r = m;
	while (l < r){
		int mid = (l + r) >> 1;
		if (c[lson[right_root]] - c[lson[left_root]] >= k){
			r = mid;
			left_root = lson[left_root];
			right_root = lson[right_root];
		}
		else{
			l = mid + 1;
			k -= c[lson[right_root]] - c[lson[left_root]];
			left_root = rson[left_root];
			right_root = rson[right_root];
		}
	}
	return l;
}
int main(){
	while (scanf("%d%d", &n, &q) == 2){
		tot = 0;
		for (int i = 1; i <= n; i++)
			scanf("%d", &a[i]);
		Init_hash();
		T[0] = build(1, m);
		for (int i = 1; i<=n; i++){
			int pos = Hash(a[i]);
			T[i] = update(T[i-1], pos, 1);
		}
		while (q--){
			int l, r, k;
			scanf("%d%d%d", &l, &r, &k);
			printf("%d\n", t[query(T[l - 1], T[r], k)]);
		}
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/chenshibo17/article/details/88561864