POJ - 2516 Minimum Cost(最小费用最大流)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/chenshibo17/article/details/88558849

Minimum Cost

Time Limit: 4000MS   Memory Limit: 65536K
Total Submissions: 19247   Accepted: 6789

Description

Dearboy, a goods victualer, now comes to a big problem, and he needs your help. In his sale area there are N shopkeepers (marked from 1 to N) which stocks goods from him.Dearboy has M supply places (marked from 1 to M), each provides K different kinds of goods (marked from 1 to K). Once shopkeepers order goods, Dearboy should arrange which supply place provide how much amount of goods to shopkeepers to cut down the total cost of transport. 

It's known that the cost to transport one unit goods for different kinds from different supply places to different shopkeepers may be different. Given each supply places' storage of K kinds of goods, N shopkeepers' order of K kinds of goods and the cost to transport goods for different kinds from different supply places to different shopkeepers, you should tell how to arrange the goods supply to minimize the total cost of transport.

Input

The input consists of multiple test cases. The first line of each test case contains three integers N, M, K (0 < N, M, K < 50), which are described above. The next N lines give the shopkeepers' orders, with each line containing K integers (there integers are belong to [0, 3]), which represents the amount of goods each shopkeeper needs. The next M lines give the supply places' storage, with each line containing K integers (there integers are also belong to [0, 3]), which represents the amount of goods stored in that supply place. 

Then come K integer matrices (each with the size N * M), the integer (this integer is belong to (0, 100)) at the i-th row, j-th column in the k-th matrix represents the cost to transport one unit of k-th goods from the j-th supply place to the i-th shopkeeper. 

The input is terminated with three "0"s. This test case should not be processed.

Output

For each test case, if Dearboy can satisfy all the needs of all the shopkeepers, print in one line an integer, which is the minimum cost; otherwise just output "-1".

Sample Input

1 3 3   
1 1 1
0 1 1
1 2 2
1 0 1
1 2 3
1 1 1
2 1 1

1 1 1
3
2
20

0 0 0

Sample Output

4

       本来以为就是一个简单的最小费用最大流。。结果被卡的不要不要的。。。一个是需要拆图,一种货物一种图进行最大流,然后就是你的数组不能开大。。本来定义的maxn = 10010;maxm = 100010;然后tle了。改成上面这个死样子之后就ac了。。真是醉了~~。

#include<iostream>
#include<cstdio>
#include<queue>
#include<algorithm>
using namespace std;
const int maxn = 7005;
const int maxm = 10500;
const int inf = 0x3f3f3f3f;
struct fuck {
	int v, ne, cap, flow, cost, u;
}ed[maxm];
int head[maxn], cnt;
int pre[maxn], dis[maxn];
bool vis[maxn];
void init(int x) {
	cnt = 0;
	for (int i = 0; i <= x; i++)
		head[i] = -1;
}
void add(int u, int v, int cap, int cost) {
	ed[cnt].v = v; ed[cnt].cap = cap; ed[cnt].flow = 0; ed[cnt].u = u;
	ed[cnt].cost = cost; ed[cnt].ne = head[u]; head[u] = cnt++;
	ed[cnt].v = u; ed[cnt].cap = 0; ed[cnt].flow = 0; ed[cnt].u = v;
	ed[cnt].cost = -cost; ed[cnt].ne = head[v]; head[v] = cnt++;
}
bool spfa(int st, int en) {
	queue<int>q;
	for (int s = 0; s <= en; s++) {//这里视情况而定
		dis[s] = inf; vis[s] = 0; pre[s] = -1;
	}
	dis[st] = 0;
	vis[st] = 1;
	q.push(st);
	while (q.size()) {
		int u = q.front(); q.pop();
		vis[u] = 0;
		for (int s = head[u]; ~s; s = ed[s].ne) {
			int v = ed[s].v;
			if (ed[s].cap > ed[s].flow&&dis[v] > dis[u] + ed[s].cost) {
				dis[v] = dis[u] + ed[s].cost;
				pre[v] = s;
				if (!vis[v]) {
					vis[v] = 1; q.push(v);
				}
			}
		}
	}
	if (pre[en] == -1)return 0;
	return 1;
}
int MinMax(int st, int en, int &cost) {
	int flow = 0;
	while (spfa(st, en)) {
		int min = inf;
		for (int s = pre[en]; ~s; s = pre[ed[s ^ 1].v]) {
			if (min > ed[s].cap - ed[s].flow)
				min = ed[s].cap - ed[s].flow;
		}
		for (int s = pre[en]; ~s; s = pre[ed[s ^ 1].v]) {
			ed[s].flow += min;
			ed[s ^ 1].flow -= min;
			cost += ed[s].cost*min;
		}
		flow += min;
	}
	return flow;
}
int n, m, k;
int thead[maxn], tcnt;
int main() {
	while (scanf("%d%d%d", &n, &m, &k) != EOF&&n + m + k != 0) {
		int st = 0, en = k * (n + m) + 1;
		init(en);
		int sum = 0;
		for (int i = 0; i < n; i++) {
			for (int j = 1; j <= k; j++) {
				int a; scanf("%d", &a);
				add(k * m + k * i + j, en, a, 0);
				sum += a;
			}
		}
		for (int i = 0; i < m; i++) {
			for (int j = 1; j <= k; j++) {
				int a; scanf("%d", &a);
				add(st, k * i + j, a, 0);
			}
		}
		tcnt = cnt;
		for (int i = 0; i <= en; i++) {
			thead[i] = head[i];
		}
		int cost = 0, need = 0;
		for (int u = 1; u <= k; u++) {
			cnt = tcnt;
			for (int i = 0; i <= en; i++)head[i] = thead[i];
			for (int i = 0; i < n; i++) {
				for (int j = 0; j < m; j++) {
					int a = k * m + k * i + u;
					int b = k * j + u;
					int c; scanf("%d", &c);
					add(b, a, inf, c);
				}
			}
			need += MinMax(st, en, cost);
		}
		if (need != sum) {
			printf("-1\n");
		}
		else {
			printf("%d\n", cost);
		}
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/chenshibo17/article/details/88558849
今日推荐