HDU1312 :RED AND BLACK(BFS or DFS)

Red and Black
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 28026 Accepted Submission(s): 16916

Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

‘.’ - a black tile
‘#’ - a red tile
‘@’ - a man on a black tile(appears exactly once in a data set)

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input
6 9
…#.
…#





#@…#
.#…#.
11 9
.#…
.#.#######.
.#.#…#.
.#.#.###.#.
.#.#…@#.#.
.#.#####.#.
.#…#.
.#########.

11 6
…#…#…#…
…#…#…#…
…#…#…###
…#…#…#@.
…#…#…#…
…#…#…#…
7 7
…#.#…
…#.#…
###.###
…@…
###.###
…#.#…
…#.#…
0 0

Sample Output
45
59
6
13

BFS版本:
用bfs的写法没什么特殊的,标记一下已走过的路,套用模板即可。

ac代码附上:

#include <stdio.h>
#include <iostream>
#include <algorithm>
#include <string.h>
#include <ctype.h>
#include <queue>
#include <cmath>
#define INF 0x3f3f3f3f
#define mod 1000000007
using namespace std;
typedef long long int ll;
char mp[25][25]; // first time: int (stupid)
int sgn[25][25];
int mv[4][2] = {{-1,0},{0,1},{1,0},{0,-1}}; // up right down left
int w,h;
int si,sj;
int sum;
struct node {
    int i,j;
};
bool check(int i,int j) {
    if(i < 1 || i > h || j < 1 || j > w) {return false;}
    if(mp[i][j] == '#') {return false;}
    if(sgn[i][j] == 1) {return false;}
    return true;
}
void bfs() {
    memset(sgn,0,sizeof(sgn));
    node cur,next;
    cur.i = si;
    cur.j = sj;
    sgn[si][sj] = 1;
    queue<node>q;
    q.push(cur);
    while(!q.empty()) {
        cur = q.front();
        q.pop();
        for(int k = 0; k < 4; k++) {
            next.i = cur.i + mv[k][0];
            next.j = cur.j + mv[k][1];
            if(check(next.i,next.j)) {
                sum++;
                sgn[next.i][next.j] = 1;
                q.push(next);
            }
        }
    }
}
int main() {
    while(cin >> w >> h) {
        if(w == 0 && h == 0) {break;}
        sum = 1;
        for(int i = 1; i <= h; i++) {
            for(int j = 1; j <= w; j++) {
                cin >> mp[i][j];
                if(mp[i][j] == '@') {
                    si = i;
                    sj = j;
                }
            }
        }
        bfs();
        cout << sum << endl;
    }
    return 0;
}

DFS版本:

记住DFS解决的是:现在要做什么

附上ac代码:

#include <stdio.h>
#include <iostream>
#include <algorithm>
#include <string.h>
#include <ctype.h>
#include <queue>
#include <cmath>
#define INF 0x3f3f3f3f
#define mod 1000000007
using namespace std;
typedef long long int ll;
char mp[25][25];
int sgn[25][25];
int w,h;
int si,sj;
int sum;
void dfs(int i,int j) {
    if(i < 1 || i > h || j < 1 || j > w || sgn[i][j] == 1 || mp[i][j] == '#') {return;}
    sgn[i][j] = 1;
    sum++;
    dfs(i-1,j); // up
    dfs(i,j+1); // right
    dfs(i+1,j); // down
    dfs(i,j-1); // left
    return;
}
int main() {
    while(cin >> w >> h) {
        if(w == 0 && h == 0) {break;}
        for(int i = 1; i <= h; i++) {
            for(int j = 1; j <= w; j++) {
                cin >> mp[i][j];
                if(mp[i][j] == '@') {
                    si = i;
                    sj = j;
                }
            }
        }
        memset(sgn,0,sizeof(sgn));
        sum = 0;
        dfs(si,sj);
        cout << sum << endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_43555854/article/details/86905694
今日推荐