OpenJ_Bailian - 2456 Aggressive cows (二分)

题目链接 https://vjudge.net/problem/316445/origin

题目

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000).

His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

Input

* Line 1: Two space-separated integers: N and C 

* Lines 2..N+1: Line i+1 contains an integer stall location, xi

Output

* Line 1: One integer: the largest minimum distance

Sample Input

5 3
1
2
8
4
9

Sample Output

3

Hint

OUTPUT DETAILS: 

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3. 

Huge input data,scanf is recommended.

思路 先将x排序,之后在 [lo,hi] 内用二分法尝试“最大最近距离” mid = (lo+hi)/2 (lo,hi 初值为[1, 1,000,000,000/C],若mid  可行,则记住该mid ,然后在新 [lo,hi] 中继续尝试 (lo= hi+1),若mid不可行,则在新 [lo,hi] 中继续尝试 (lo= hi-1)。

1) 第1头牛放在X0
2) 若第k头牛放在Xi ,则找到Xi+1 到
到Xn-1中第一个位于 [Xi+mid, 1000000000] 中的Xj
第k+1头牛放在Xj

AC代码
 

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<string>
using namespace std;
long long s[100005];
int main()
{
    int n,c;
    cin>>n>>c;
    for(int i=0;i<n;i++){
        scanf("%d",&s[i]);
    }
    sort(s,s+n);
    int hi=1000000000/c;
    int lo=1;
    int sum;
    int mid;
    while(lo<=hi){
            sum=1;
            mid=lo+(hi-lo)/2;
            int i=s[0]+mid;
            for(int j=1;j<n;j++){
                if(s[j]>=i&&s[j]<=1000000000){
                    sum++;
                    i=s[j]+mid;
                    if(sum==c)
                        break;
                }
            }
            if(sum==c)
                lo=mid+1;
            else
                hi=mid-1;
    }
    cout<<hi<<endl;
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_37291934/article/details/89231077